Menu icon Foundation
Bower fails to create new Foundation project

I'm tryng to create a new project using Foundation on Windows 8.1
I did this in Windows 7 simply enough, no problems at all, but now I'm having trouble.
I have Git, Ruby and NodeJSThis is what I get when I try to install foundation.

E:\Dropbox\www>foundation new sample --libsass
Creating ./sample
      create  sample
remote: Counting objects: 28, done.
remote: Compressing objects: 100% (18/18), done.
remote: Total 28 (delta 8), reused 24 (delta 4)
Unpacking objects: 100% (28/28), done.

Installing dependencies with bower...
C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/thor-0.18.1/lib/thor/actions.rb:252:in `
`': No such file or directory - bower install (Errno::ENOENT)
        from C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/thor-0.18.1/lib/thor/action
s.rb:252:in `run'
        from C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/foundation-1.0.4/lib/founda
tion/cli/generator.rb:130:in `block in new'
        from C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/thor-0.18.1/lib/thor/action
s.rb:182:in `block in inside'
        from C:/Ruby200-x64/lib/ruby/2.0.0/fileutils.rb:125:in `chdir'
        from C:/Ruby200-x64/lib/ruby/2.0.0/fileutils.rb:125:in `cd'
        from C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/thor-0.18.1/lib/thor/action
s.rb:182:in `inside'
        from C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/foundation-1.0.4/lib/founda
tion/cli/generator.rb:128:in `new'
        from C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/thor-0.18.1/lib/thor/comman
d.rb:27:in `run'
        from C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/thor-0.18.1/lib/thor/invoca
tion.rb:120:in `invoke_command'
        from C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/thor-0.18.1/lib/thor.rb:363
:in `dispatch'
        from C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/thor-0.18.1/lib/thor/base.r
b:439:in `start'
        from C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/foundation-1.0.4/bin/founda
tion:4:in `<top (required)>'
        from C:/Ruby200-x64/bin/foundation:23:in `load'
        from C:/Ruby200-x64/bin/foundation:23:in `<main>'
            

         

After this, I get the folder with an incomplete copy of Foundation.
Can anyone help me please?

bowercliCommand LineFoundationFoundation 5

I'm tryng to create a new project using Foundation on Windows 8.1
I did this in Windows 7 simply enough, no problems at all, but now I'm having trouble.
I have Git, Ruby and NodeJSThis is what I get when I try to install foundation.

E:\Dropbox\www>foundation new sample --libsass
Creating ./sample
      create  sample
remote: Counting objects: 28, done.
remote: Compressing objects: 100% (18/18), done.
remote: Total 28 (delta 8), reused 24 (delta 4)
Unpacking objects: 100% (28/28), done.

Installing dependencies with bower...
C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/thor-0.18.1/lib/thor/actions.rb:252:in `
`': No such file or directory - bower install (Errno::ENOENT)
        from C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/thor-0.18.1/lib/thor/action
s.rb:252:in `run'
        from C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/foundation-1.0.4/lib/founda
tion/cli/generator.rb:130:in `block in new'
        from C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/thor-0.18.1/lib/thor/action
s.rb:182:in `block in inside'
        from C:/Ruby200-x64/lib/ruby/2.0.0/fileutils.rb:125:in `chdir'
        from C:/Ruby200-x64/lib/ruby/2.0.0/fileutils.rb:125:in `cd'
        from C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/thor-0.18.1/lib/thor/action
s.rb:182:in `inside'
        from C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/foundation-1.0.4/lib/founda
tion/cli/generator.rb:128:in `new'
        from C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/thor-0.18.1/lib/thor/comman
d.rb:27:in `run'
        from C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/thor-0.18.1/lib/thor/invoca
tion.rb:120:in `invoke_command'
        from C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/thor-0.18.1/lib/thor.rb:363
:in `dispatch'
        from C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/thor-0.18.1/lib/thor/base.r
b:439:in `start'
        from C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/foundation-1.0.4/bin/founda
tion:4:in `<top (required)>'
        from C:/Ruby200-x64/bin/foundation:23:in `load'
        from C:/Ruby200-x64/bin/foundation:23:in `<main>'
            

         

After this, I get the folder with an incomplete copy of Foundation.
Can anyone help me please?

Kirill Stepanov almost 6 years ago

I've got same problem in Win 7.
Here is one possible solution https://github.com/zurb/foundation/issues/3651
But i installed git for cmd, so seems it doesn't solve my case, but you may try.