Menu icon Foundation
Foundation 5 sass changing settings...

Foundation 5 seems to have deleted all typography variables in the _settings.scss. If i copy them over (for example // We use these to style the hr element
$hr-border-width: 1px;
$hr-border-style: solid;
$hr-border-color: #ddd;
$hr-margin: rem-calc(200);)

Here i changed the value of $hr-margin to 200. It has absolutely no effect. In the same settings file it says
/ Uncomment to use rem-calc() in your settings
//@import "foundation/functions";

But when i do this, i get a compile error:>>> Change detected at 10:06:36 to: _settings-testfoundation5.scss
error scss/app.scss (Line 49 of scss/_settings-testfoundation5.scss: Undefined variable: "$rem-base".)
overwrite stylesheets/app.css

Is there anyone who can shine a light on this?
Thanks,
Guy

settingsSassscsschangingdefaultfont-size

Foundation 5 seems to have deleted all typography variables in the _settings.scss. If i copy them over (for example // We use these to style the hr element
$hr-border-width: 1px;
$hr-border-style: solid;
$hr-border-color: #ddd;
$hr-margin: rem-calc(200);)

Here i changed the value of $hr-margin to 200. It has absolutely no effect. In the same settings file it says
/ Uncomment to use rem-calc() in your settings
//@import "foundation/functions";

But when i do this, i get a compile error:>>> Change detected at 10:06:36 to: _settings-testfoundation5.scss
error scss/app.scss (Line 49 of scss/_settings-testfoundation5.scss: Undefined variable: "$rem-base".)
overwrite stylesheets/app.css

Is there anyone who can shine a light on this?
Thanks,
Guy


Guy Van Bael gave the most helpful answer for this post
Guy Van Bael about 5 years ago

Got it...

I had to put !default to this:
// This is the default html and body font-size for the base rem value.
$rem-base: 16px !default;

Probably will be corrected by the Zurbians in the next update.

This post has been closed. No new replies can be added.

Julian Ćwirko about 5 years ago

try to set $rem-base: 16px;

Guy Van Bael about 5 years ago

Got it...

I had to put !default to this:
// This is the default html and body font-size for the base rem value.
$rem-base: 16px !default;

Probably will be corrected by the Zurbians in the next update.

Rafi Benkual about 5 years ago

This is fixed in the master now.

Official release will have fix in 5.0.3