Menu icon Foundation
Foundation 6 Mac, VMWare & Ubuntu 18

Hi,

 

If you're running Foundation 6.5 in a virtual machine that watches files shared on VMWare folder, this is a question for you.

---

I have my project files in a folder on my mac. I have Ubuntu running in a virtual machine under VMWare. I have Foundation 6.5 installed on the Ubuntu system where it watches the shared folder on my mac e.g. /mnt/hgfs/myproject

My problem is when I save my .scss files on the mac side, "foundation watch" running on Ubuntu doesn't see the file changes, in other words grunt doesn't see the file changes and process processes my sass into css files. However, if I change the files on the Ubuntu side, grunt/foundation sees the changes and processes the sass into css.

On the other hand, I'm doing the same with Foundation 5.3, and when I save my .sass files on the mac, grunt on the Ubuntu side sees the changes and compiles them into .css files. So, this setup  works with Foundaiton 5.3, but, not 6.5.

Has anyone running the latest VMWare with Ubuntu that monitors files over a shared folder had this issue with Foundation 6.5? Fix?

 

vmwaremacubuntuFoundationsites

Hi,

 

If you're running Foundation 6.5 in a virtual machine that watches files shared on VMWare folder, this is a question for you.

---

I have my project files in a folder on my mac. I have Ubuntu running in a virtual machine under VMWare. I have Foundation 6.5 installed on the Ubuntu system where it watches the shared folder on my mac e.g. /mnt/hgfs/myproject

My problem is when I save my .scss files on the mac side, "foundation watch" running on Ubuntu doesn't see the file changes, in other words grunt doesn't see the file changes and process processes my sass into css files. However, if I change the files on the Ubuntu side, grunt/foundation sees the changes and processes the sass into css.

On the other hand, I'm doing the same with Foundation 5.3, and when I save my .sass files on the mac, grunt on the Ubuntu side sees the changes and compiles them into .css files. So, this setup  works with Foundaiton 5.3, but, not 6.5.

Has anyone running the latest VMWare with Ubuntu that monitors files over a shared folder had this issue with Foundation 6.5? Fix?