Menu icon Foundation
Default install using foundation-cli does not work on Windows 10

I am completely new to foundation and mostly new to Angular and trying out the basics!

I ran the npm install for foundation-cli and then ran foundation new and selected foundation sites and the basic template. It showed me a ton of errors when trying to download a node-sass download from github which then caused another load of errors. The github error was 404 for github.com/sass/node-sass/releases/download/v3.13.1/win32-x64-57_binding.node

After some digging, I discovered that the foundation-cli template requires a very old version of gulp-sass (^2.10.0) which has a dependency on node-sass (^3.4.2), which finds 3.13.1, which for some reason does not have a binding for Windows 10b57, possibly because 3.13 is old too at approx 2 years?

I had to edit package.json and updated the gulp-sass version to the latest (4.0.1), deleted node_modules and package.json.lock (?) and then ran npm install again and it all seemed to install without error.

It would be nice if these templates were kept up-to-date so that the first hurdle isn't the hardest. Foundation looks pretty sweet too!

windowsWindows 10Newbie

I am completely new to foundation and mostly new to Angular and trying out the basics!

I ran the npm install for foundation-cli and then ran foundation new and selected foundation sites and the basic template. It showed me a ton of errors when trying to download a node-sass download from github which then caused another load of errors. The github error was 404 for github.com/sass/node-sass/releases/download/v3.13.1/win32-x64-57_binding.node

After some digging, I discovered that the foundation-cli template requires a very old version of gulp-sass (^2.10.0) which has a dependency on node-sass (^3.4.2), which finds 3.13.1, which for some reason does not have a binding for Windows 10b57, possibly because 3.13 is old too at approx 2 years?

I had to edit package.json and updated the gulp-sass version to the latest (4.0.1), deleted node_modules and package.json.lock (?) and then ran npm install again and it all seemed to install without error.

It would be nice if these templates were kept up-to-date so that the first hurdle isn't the hardest. Foundation looks pretty sweet too!