Menu icon Foundation
Problem start new project error sass OSX 10.13.3 64-bits

Hello,

 

I have problems to create a new project foundation-sites basic template concerning sass. Indeed, I have the error:

 

Error: Node Sass does not yet support your current environment: OS X 64-bit with Unsupported runtime (59)

For more information on which environments are supported please see:

https://github.com/sass/node-sass/releases/tag/v3.13.1

    at module.exports (/Users/ricardo_do_vale/Sites/Foundation-Sites/dvwdesign-offcanvas/node_modules/gulp-sass/node_modules/node-sass/lib/binding.js:13:13)

    at Object.<anonymous> (/Users/ricardo_do_vale/Sites/Foundation-Sites/dvwdesign-offcanvas/node_modules/gulp-sass/node_modules/node-sass/lib/index.js:14:35)

    at Module._compile (module.js:662:30)

    at Object.Module._extensions..js (module.js:673:10)

    at Module.load (module.js:575:32)

    at tryModuleLoad (module.js:515:12)

    at Function.Module._load (module.js:507:3)

    at Module.require (module.js:606:17)

    at require (internal/module.js:11:18)

    at Object.<anonymous> (/Users/ricardo_do_vale/Sites/Foundation-Sites/dvwdesign-offcanvas/node_modules/gulp-sass/index.js:187:21)

npm ERR! code ELIFECYCLE

npm ERR! errno 1

npm ERR! [email protected] start: `gulp`

npm ERR! Exit status 1

npm ERR! 

npm ERR! Failed at the [email protected] start script.

 

npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

 

I looked at some articles on it, and I did a npm rebuild node-sass, but without success.

 

How can I solve this problem?

 

versions:

Mac OSX 10.13.3

node v9.7.1

npm 5.7.1

 

foundation cli 2.2.5

node-sassstart project

Hello,

 

I have problems to create a new project foundation-sites basic template concerning sass. Indeed, I have the error:

 

Error: Node Sass does not yet support your current environment: OS X 64-bit with Unsupported runtime (59)

For more information on which environments are supported please see:

https://github.com/sass/node-sass/releases/tag/v3.13.1

    at module.exports (/Users/ricardo_do_vale/Sites/Foundation-Sites/dvwdesign-offcanvas/node_modules/gulp-sass/node_modules/node-sass/lib/binding.js:13:13)

    at Object.<anonymous> (/Users/ricardo_do_vale/Sites/Foundation-Sites/dvwdesign-offcanvas/node_modules/gulp-sass/node_modules/node-sass/lib/index.js:14:35)

    at Module._compile (module.js:662:30)

    at Object.Module._extensions..js (module.js:673:10)

    at Module.load (module.js:575:32)

    at tryModuleLoad (module.js:515:12)

    at Function.Module._load (module.js:507:3)

    at Module.require (module.js:606:17)

    at require (internal/module.js:11:18)

    at Object.<anonymous> (/Users/ricardo_do_vale/Sites/Foundation-Sites/dvwdesign-offcanvas/node_modules/gulp-sass/index.js:187:21)

npm ERR! code ELIFECYCLE

npm ERR! errno 1

npm ERR! [email protected] start: `gulp`

npm ERR! Exit status 1

npm ERR! 

npm ERR! Failed at the [email protected] start script.

 

npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

 

I looked at some articles on it, and I did a npm rebuild node-sass, but without success.

 

How can I solve this problem?

 

versions:

Mac OSX 10.13.3

node v9.7.1

npm 5.7.1

 

foundation cli 2.2.5