Menu icon Foundation
Node-Sass error on default foundation for email project

I've created a new email project per https://foundation.zurb.com/emails/docs/sass-guide.html. When I run "npm start" it's failing when it gets to the sass part of the build (Error: Node Sass does not support your current environment: Windows 64-bit with Upsupported runtime (57)). I've deleted the node_modules folder and re-installed them and tried installing node-sass manually. Not sure what else to try.

npm version 5.5.1

node version: 8.9.1

node-sass version: 4.6.1

node-sassemailgulp

I've created a new email project per https://foundation.zurb.com/emails/docs/sass-guide.html. When I run "npm start" it's failing when it gets to the sass part of the build (Error: Node Sass does not support your current environment: Windows 64-bit with Upsupported runtime (57)). I've deleted the node_modules folder and re-installed them and tried installing node-sass manually. Not sure what else to try.

npm version 5.5.1

node version: 8.9.1

node-sass version: 4.6.1

This post has been closed. No new replies can be added.

Corey Schaaf almost 2 years ago

Based on your build the following OS / Architectures are supported. Are you 

https://github.com/sass/node-sass/releases/tag/v3.13.1

Andrew Henning almost 2 years ago

Github no longer hosts the binaries for node-sass v3.13.1.

That version of node-sass is required by gulp-sass 2.1.0, which is also quite old. The official ZURB template also references a half dozen other outdated/deprecated packages, i.e. the whole Foundation for Sites 6.4.3 could use some updating IMHO.

I think the easiest way to fix your error is simply to update the package.json file.

Change:

"gulp-sass": "^2.1.0",

to:

"gulp-sass": "^3.1.0",

then run:

npm install

AFAIK the 3.x line is backwards compatible, and it eliminates your problem, as this selects a newer set of node-sass binaries to download. I've not seen any other issue pop up as a result of this change.

Jason Kendall almost 2 years ago

 Thanks for the responses guys. Andrew, I tried updating the package file per your response but it's still bombing out. Anything else in this little bit of code that needs to be updated/changed?

 

 "gulp-sass": {

            "version": "^3.1.0",

            "resolved": "https://registry.npmjs.org/gulp-sass/-/gulp-sass-3.1.0.tgz",

            "integrity": "sha1-U9xLaKH13f5EJKtMJHZVJpqLdLc=",

            "dev": true,

            "requires": {

                "gulp-util": "3.0.8",

                "lodash.clonedeep": "4.5.0",

                "node-sass": "4.7.2",

                "through2": "2.0.3",

                "vinyl-sourcemaps-apply": "0.2.1"

            } 

Corey I'm not sure what you're asking. Did your response get cut off?

 

Jason Kendall almost 2 years ago

UPDATE: Ok so not I downloaded a clean copy of the email starter projects and started comparing the package.js files with my project files. As you can see from what I posted above, my project package.js file is totally different from the template package.js file. I'm not sure where all of the keys for gulp-sass came from in my file because I didn't add those. gulp-sass should just look like this with the version number. 

"gulp-sass": "^3.1.0",

I updated it to ^3.1.0 from ^2.1.0 per Andrews recommendation and it all compiled correctly without errors. I also downgraded node to version 7.0 beforehand but not sure if that was an issue or not.

Thank you Andrew and Corey!