Menu icon Foundation
Can't get jQuery UI to work in ZF 6.4

I'm currently upgrading a project I'm working on from ZF 6.3 to 6.4. The CSS is done and it work fine. Now I'm trying to get all my Javascript stuff to work. But I'm stuck.

I'd like to have a single code base (all my scripts in app.js). At the moment I try to get jQuery UI to work. I installed the npm package by using »npm install jquery-ui« command. After that I add

import ui from 'jquery-ui'

to the app.js.

But when I try to use a UI function like .autocomplete() or .progressbar() the console says ».progressbar is not a function«. This tells me that the import of jQuery UI hasn't work properly.

What am I'm doing wrong?I have to say that I'm quite new to Webpack. But my whole site isn't working at the moment and I would really like to take advantage of ZF 6.4 and its XY Grid since 6.3 isn't maintained anymore.

Is there anybody able to help?

javascriptjquery-uifoundation 6.4webpack

I'm currently upgrading a project I'm working on from ZF 6.3 to 6.4. The CSS is done and it work fine. Now I'm trying to get all my Javascript stuff to work. But I'm stuck.

I'd like to have a single code base (all my scripts in app.js). At the moment I try to get jQuery UI to work. I installed the npm package by using »npm install jquery-ui« command. After that I add

import ui from 'jquery-ui'

to the app.js.

But when I try to use a UI function like .autocomplete() or .progressbar() the console says ».progressbar is not a function«. This tells me that the import of jQuery UI hasn't work properly.

What am I'm doing wrong?I have to say that I'm quite new to Webpack. But my whole site isn't working at the moment and I would really like to take advantage of ZF 6.4 and its XY Grid since 6.3 isn't maintained anymore.

Is there anybody able to help?