Menu icon Foundation
How to fix Libsass: Error: File to import not found or unreadable: util/util

 

Hi There,

I was using Foundation v4 and am trying to use v6 but keep getting an error on compile.

I used Codekit to install but have since moved the /assets directory (containing the foundation install) a level deeper into a /theme directory and updated the paths. But I keep seeing the following error on compile:

Libsass: Error: File to import not found or unreadable: util/util.
       Parent style sheet: /Users/user/Sites/website/theme/assets/scss/_settings.scss

        on line 63 of Users/user/Sites/website/theme/assets/scss/_settings.scss
>> @import 'util/util';

The paths I've found are relative within the assets directory (so are correct), codekit has no issues finding the Foundation install, but I can't find any hard-coded paths.

Does anyone know what might be misconfigured now that the /assets directory is one level deeper inside the /themes directory?

Any help would be much appreciated - going crazy here!

Cheers

 

 

Sass compile error

 

Hi There,

I was using Foundation v4 and am trying to use v6 but keep getting an error on compile.

I used Codekit to install but have since moved the /assets directory (containing the foundation install) a level deeper into a /theme directory and updated the paths. But I keep seeing the following error on compile:

Libsass: Error: File to import not found or unreadable: util/util.
       Parent style sheet: /Users/user/Sites/website/theme/assets/scss/_settings.scss

        on line 63 of Users/user/Sites/website/theme/assets/scss/_settings.scss
>> @import 'util/util';

The paths I've found are relative within the assets directory (so are correct), codekit has no issues finding the Foundation install, but I can't find any hard-coded paths.

Does anyone know what might be misconfigured now that the /assets directory is one level deeper inside the /themes directory?

Any help would be much appreciated - going crazy here!

Cheers

 

 

Brandon Richards about 2 years ago

I'm having this same issue with Foundation 6 in Codekit. The path can't be found because there isn't a bower_components folder.

Mario Peischl about 2 years ago

Same here. Using F6 with CodeKit and without Compass. F6 is installed with npm. Don't know since when this errors appeared, because weeks ago CodeKit compiled the file without any error. 

Cheers

Mario

Mario Peischl about 2 years ago

For now i fixed it by changing 

@import 'util/util';

to

@import '../util/util';

in the _settings.scss on line 63. 

 

It's not the safest solution because an Foundation Update will overwrite it every time. But because in CodeKit i cannot set the "path" i don't know what to do else. 

Cheers

Mario

Kars almost 2 years ago

You can try this err_cache_miss chrome thanks.

Mario Peischl almost 2 years ago

@Kars 

I don't know or understand what your reply has to do with this Libsass error message. 

Tiago De Sousa almost 2 years ago

 I'm having exactly the same issue and changing the path to

@import '../util/util';

it just doesn't fix it for me :(

Did you manage to solve the issue?