Menu icon Foundation
Huge problem on IE11 and Edge. Foundation completely breaking the slider.

You can see for yourself. Here http://eebeauce.com/

As you can see the slider DIV is completely out of sense with thousands, sometimes millions of pixel of width.

I tried to use the debugger, at first I thought this happened because the foundation script was loaded at the end. I tried using defer, changing it and putting it a top but nothing worked.

Maybe you can help me with it as I'm starting to give up. Nobody, where I work, is able to get where the problem happens. All we know is that it happens during that foundation function. Now, that function uses a little bit of tag manager and a little bit of font-awesome.

The font-awesome part seems to be the problem but it's being called by Foundation which is why I'm writing this here.
I know it's annoying the debug (the index page number of line change with each refresh so the breakpoint doesn't work half of the time).

We don't know what is causing this to happen. It works with Chrome in EDGE or IE11 compatibility mode but it doesn't work in EDGE or IE11 in Chrome compatibility mode.

The client is starting to get mad since at first, we thought this would be a simple javascript problem (which it seem it was) but there is no way of knowing why the slider width completely explode.

Anyway, I hope you guys can help me. This is super important.

Edit: Bump because still unanswered.

edgeie11sliderwidth

You can see for yourself. Here http://eebeauce.com/

As you can see the slider DIV is completely out of sense with thousands, sometimes millions of pixel of width.

I tried to use the debugger, at first I thought this happened because the foundation script was loaded at the end. I tried using defer, changing it and putting it a top but nothing worked.

Maybe you can help me with it as I'm starting to give up. Nobody, where I work, is able to get where the problem happens. All we know is that it happens during that foundation function. Now, that function uses a little bit of tag manager and a little bit of font-awesome.

The font-awesome part seems to be the problem but it's being called by Foundation which is why I'm writing this here.
I know it's annoying the debug (the index page number of line change with each refresh so the breakpoint doesn't work half of the time).

We don't know what is causing this to happen. It works with Chrome in EDGE or IE11 compatibility mode but it doesn't work in EDGE or IE11 in Chrome compatibility mode.

The client is starting to get mad since at first, we thought this would be a simple javascript problem (which it seem it was) but there is no way of knowing why the slider width completely explode.

Anyway, I hope you guys can help me. This is super important.

Edit: Bump because still unanswered.