Menu icon Foundation
Error: Cannot find module config-chain

Update was available:

 Update available: 2.2.3 (current: 2.2.1)   │ Run npm update -g foundation-cli to update.

 

Ran it. Seemed to go ok. However, now whenever I run the command "foundation" at c prompt, I get this:

module.js:328
    throw err;
    ^

Error: Cannot find module 'config-chain'
    at Function.Module._resolveFilename (module.js:326:15)
    at Function.Module._load (module.js:277:25)
    at Module.require (module.js:354:17)
    at require (internal/module.js:12:17)
    at Object.<anonymous> (C:\Users\me\AppData\Roaming\npm\node_modules\foundation-cli\node_modules\npm\lib\config\core.js:2:10)
    at Module._compile (module.js:398:26)
    at Object.Module._extensions..js (module.js:405:10)
    at Module.load (module.js:344:32)
    at Function.Module._load (module.js:301:12)
    at Module.require (module.js:354:17)
    at require (internal/module.js:12:17)

No idea what this means. I don't know anything about npm and everything that makes foundation run. I followed instructions and it has all worked for years. Any help would be appreciated. 

It appeared to update ok in my command prompt and ended with "foundation-cli@2.2.3". I only saw this warning at the top: npm WARN deprecated bower@1.8.0: ..psst! While Bower is maintained, we recommend Yarn. 

I'm guessing this is a different situation and i'm not ready to stop using bower if it's still working.

foundation 6sites

Update was available:

 Update available: 2.2.3 (current: 2.2.1)   │ Run npm update -g foundation-cli to update.

 

Ran it. Seemed to go ok. However, now whenever I run the command "foundation" at c prompt, I get this:

module.js:328
    throw err;
    ^

Error: Cannot find module 'config-chain'
    at Function.Module._resolveFilename (module.js:326:15)
    at Function.Module._load (module.js:277:25)
    at Module.require (module.js:354:17)
    at require (internal/module.js:12:17)
    at Object.<anonymous> (C:\Users\me\AppData\Roaming\npm\node_modules\foundation-cli\node_modules\npm\lib\config\core.js:2:10)
    at Module._compile (module.js:398:26)
    at Object.Module._extensions..js (module.js:405:10)
    at Module.load (module.js:344:32)
    at Function.Module._load (module.js:301:12)
    at Module.require (module.js:354:17)
    at require (internal/module.js:12:17)

No idea what this means. I don't know anything about npm and everything that makes foundation run. I followed instructions and it has all worked for years. Any help would be appreciated. 

It appeared to update ok in my command prompt and ended with "foundation-cli@2.2.3". I only saw this warning at the top: npm WARN deprecated bower@1.8.0: ..psst! While Bower is maintained, we recommend Yarn. 

I'm guessing this is a different situation and i'm not ready to stop using bower if it's still working.

Robert Truex almost 2 years ago

I am having this same issue after updating foundation-cli from 2.1.0 to current.

Robert Truex almost 2 years ago

I tried all kinds of uninstall/install/updating. It seemed like when I updated Bower -g  that foundation-cli started working properly.

Tonybyte almost 2 years ago

Thanks Robert but what exactly do I type? bower update -g ? That updated packages but didnt resolve this for me. :(

 

bower version is 1.8.0

npm version 3.3.12

Robert Truex almost 2 years ago

I updated to bower 1.8.0, npm 5.3.0 and foundation 2.2.3. I'm not great with CLI, I had to install and update things and eventually got it working. Sorry I can't be more helpful.

 

Tonybyte almost 2 years ago

Thanks Robert. Unfortunately, I still haven't resolved this.