Menu icon Foundation
Problems when I start a new project

Hello I have  problem when i try to start a project with foundation cli. The node modules not are installet and this is the message error:

 

SyntaxError: Unexpected token ) at createScript (vm.js:74:10) at Object.runInThisContext (vm.js:116:10) at Module._compile (module.js:533:28) at Object.Module._extensions..js (module.js:580:10) at Module.load (module.js:503:32) at tryModuleLoad (module.js:466:12) at Function.Module._load (module.js:458:3) at Module.require (module.js:513:17) at require (internal/module.js:11:18) at Object. (C:\npmhost\news1\node_modules\gulp-imagemin\node_modules\gulp-util\node_modules\has-gulplog\index.js:3:16)

phantomjs-prebuilt@2.1.14 install C:\npmhost\news1\node_modules\gulp-uncss\node_modules\uncss\node_modules\phridge\node_modules\phantomjs-prebuilt node install.js

Considering PhantomJS found at C:\Users\ivano\AppData\Roaming\npm\phantomjs.CMD Looks like an npm install -g on windows; skipping installed version. Download already available at C:\Users\ivano\AppData\Local\Temp\phantomjs\phantomjs-2.1.1-windows.zip Verified checksum of previously downloaded file Extracting zip contents Removing C:\npmhost\news1\node_modules\gulp-uncss\node_modules\uncss\node_modules\phridge\node_modules\phantomjs-prebuilt\lib\phantom Copying extracted folder C:\Users\ivano\AppData\Local\Temp\phantomjs\phantomjs-2.1.1-windows.zip-extract-1500400643490\phantomjs-2.1.1-windows -> C:\npmhost\news1\node_modules\gulp-uncss\node_modules\uncss\node_modules\phridge\node_modules\phantomjs-prebuilt\lib\phantom Writing location.js file Done. Phantomjs binary available at C:\npmhost\news1\node_modules\gulp-uncss\node_modules\uncss\node_modules\phridge\node_modules\phantomjs-prebuilt\lib\phantom\bin\phantomjs.exe \ node-sass@3.13.1 install C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass node scripts/install.js

Downloading binary from https://github.com/sass/node-sass/releases/download/v3.13.1/win32-x64-57_binding.node Cannot download "https://github.com/sass/node-sass/releases/download/v3.13.1/win32-x64-57_binding.node":

HTTP error 404 Not Found

Hint: If github.com is not accessible in your location try setting a proxy via HTTP_PROXY, e.g.

  export HTTP_PROXY=http://example.com:1234

or configure npm proxy via

  npm config set proxy http://example.com:8080

node-sass@3.13.1 postinstall C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass node scripts/build.js

Building: C:\Program Files\nodejs\node.exe C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\bin\node-gyp.js rebuild --verbose --libsass_ext= --libsass_cflags= --libsass_ldflags= --libsass_library= gyp info it worked if it ends with ok gyp verb cli [ 'C:\Program Files\nodejs\node.exe', gyp verb cli 'C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\bin\node-gyp.js', gyp verb cli 'rebuild', gyp verb cli '--verbose', gyp verb cli '--libsass_ext=', gyp verb cli '--libsass_cflags=', gyp verb cli '--libsass_ldflags=', gyp verb cli '--libsass_library=' ] gyp info using node-gyp@3.6.2 gyp info using node@8.1.4 | win32 | x64 gyp verb command rebuild [] gyp verb command clean [] gyp verb clean removing "build" directory gyp verb command configure [] gyp verb check python checking for Python executable "python2" in the PATH gyp verb which failed Error: not found: python2 gyp verb which failed at getNotFoundError (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:13:12) gyp verb which failed at F (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:68:19) gyp verb which failed at E (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:80:29) gyp verb which failed at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:89:16 gyp verb which failed at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\index.js:42:5 gyp verb which failed at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\windows.js:36:5 gyp verb which failed at FSReqWrap.oncomplete (fs.js:152:21) gyp verb which failed python2 { Error: not found: python2 gyp verb which failed at getNotFoundError (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:13:12) gyp verb which failed at F (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:68:19) gyp verb which failed at E (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:80:29) gyp verb which failed at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:89:16 gyp verb which failed at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\index.js:42:5 gyp verb which failed at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\windows.js:36:5 gyp verb which failed at FSReqWrap.oncomplete (fs.js:152:21) gyp verb which failed stack: 'Error: not found: python2\n at getNotFoundError (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:13:12)\n at F (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:68:19)\n at E (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:80:29)\n at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:89:16\n at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\index.js:42:5\n at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\windows.js:36:5\n at FSReqWrap.oncomplete (fs.js:152:21)', gyp verb which failed code: 'ENOENT' } gyp verb check python checking for Python executable "python" in the PATH gyp verb which failed Error: not found: python gyp verb which failed at getNotFoundError (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:13:12) gyp verb which failed at F (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:68:19) gyp verb which failed at E (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:80:29) gyp verb which failed at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:89:16 gyp verb which failed at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\index.js:42:5 gyp verb which failed at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\windows.js:36:5 gyp verb which failed at FSReqWrap.oncomplete (fs.js:152:21) gyp verb which failed python { Error: not found: python gyp verb which failed at getNotFoundError (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:13:12) gyp verb which failed at F (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:68:19) gyp verb which failed at E (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:80:29) gyp verb which failed at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:89:16 gyp verb which failed at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\index.js:42:5 gyp verb which failed at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\windows.js:36:5 gyp verb which failed at FSReqWrap.oncomplete (fs.js:152:21) gyp verb which failed stack: 'Error: not found: python\n at getNotFoundError (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:13:12)\n at F (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:68:19)\n at E (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:80:29)\n at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:89:16\n at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\index.js:42:5\n at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\windows.js:36:5\n at FSReqWrap.oncomplete (fs.js:152:21)', gyp verb which failed code: 'ENOENT' } gyp verb could not find "python". checking python launcher gyp verb could not find "python". guessing location gyp verb ensuring that file exists: C:\Python27\python.exe gyp ERR! configure error gyp ERR! stack Error: Can't find Python executable "python", you can set the PYTHON env variable. gyp ERR! stack at PythonFinder.failNoPython (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\lib\configure.js:483:19) gyp ERR! stack at PythonFinder. (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\lib\configure.js:508:16) gyp ERR! stack at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\graceful-fs\polyfills.js:284:29 gyp ERR! stack at FSReqWrap.oncomplete (fs.js:152:21) gyp ERR! System Windows_NT 10.0.15063 gyp ERR! command "C:\Program Files\nodejs\node.exe" "C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\bin\node-gyp.js" "rebuild" "--verbose" "--libsass_ext=" "--libsass_cflags=" "--libsass_ldflags=" "--libsass_library=" gyp ERR! cwd C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass gyp ERR! node -v v8.1.4 gyp ERR! node-gyp -v v3.6.2 gyp ERR! not ok Build failed with error code: 1

There were some problems during the installation.

✓ New project folder created. ✗ Node modules not installed. Try running npm install manually. ✓ Bower components installed.

 

Once you've resolved the above issues, run foundation watch while inside the news1 folder.

foundation-clinpmgyp

Hello I have  problem when i try to start a project with foundation cli. The node modules not are installet and this is the message error:

 

SyntaxError: Unexpected token ) at createScript (vm.js:74:10) at Object.runInThisContext (vm.js:116:10) at Module._compile (module.js:533:28) at Object.Module._extensions..js (module.js:580:10) at Module.load (module.js:503:32) at tryModuleLoad (module.js:466:12) at Function.Module._load (module.js:458:3) at Module.require (module.js:513:17) at require (internal/module.js:11:18) at Object. (C:\npmhost\news1\node_modules\gulp-imagemin\node_modules\gulp-util\node_modules\has-gulplog\index.js:3:16)

phantomjs-prebuilt@2.1.14 install C:\npmhost\news1\node_modules\gulp-uncss\node_modules\uncss\node_modules\phridge\node_modules\phantomjs-prebuilt node install.js

Considering PhantomJS found at C:\Users\ivano\AppData\Roaming\npm\phantomjs.CMD Looks like an npm install -g on windows; skipping installed version. Download already available at C:\Users\ivano\AppData\Local\Temp\phantomjs\phantomjs-2.1.1-windows.zip Verified checksum of previously downloaded file Extracting zip contents Removing C:\npmhost\news1\node_modules\gulp-uncss\node_modules\uncss\node_modules\phridge\node_modules\phantomjs-prebuilt\lib\phantom Copying extracted folder C:\Users\ivano\AppData\Local\Temp\phantomjs\phantomjs-2.1.1-windows.zip-extract-1500400643490\phantomjs-2.1.1-windows -> C:\npmhost\news1\node_modules\gulp-uncss\node_modules\uncss\node_modules\phridge\node_modules\phantomjs-prebuilt\lib\phantom Writing location.js file Done. Phantomjs binary available at C:\npmhost\news1\node_modules\gulp-uncss\node_modules\uncss\node_modules\phridge\node_modules\phantomjs-prebuilt\lib\phantom\bin\phantomjs.exe \ node-sass@3.13.1 install C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass node scripts/install.js

Downloading binary from https://github.com/sass/node-sass/releases/download/v3.13.1/win32-x64-57_binding.node Cannot download "https://github.com/sass/node-sass/releases/download/v3.13.1/win32-x64-57_binding.node":

HTTP error 404 Not Found

Hint: If github.com is not accessible in your location try setting a proxy via HTTP_PROXY, e.g.

  export HTTP_PROXY=http://example.com:1234

or configure npm proxy via

  npm config set proxy http://example.com:8080

node-sass@3.13.1 postinstall C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass node scripts/build.js

Building: C:\Program Files\nodejs\node.exe C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\bin\node-gyp.js rebuild --verbose --libsass_ext= --libsass_cflags= --libsass_ldflags= --libsass_library= gyp info it worked if it ends with ok gyp verb cli [ 'C:\Program Files\nodejs\node.exe', gyp verb cli 'C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\bin\node-gyp.js', gyp verb cli 'rebuild', gyp verb cli '--verbose', gyp verb cli '--libsass_ext=', gyp verb cli '--libsass_cflags=', gyp verb cli '--libsass_ldflags=', gyp verb cli '--libsass_library=' ] gyp info using node-gyp@3.6.2 gyp info using node@8.1.4 | win32 | x64 gyp verb command rebuild [] gyp verb command clean [] gyp verb clean removing "build" directory gyp verb command configure [] gyp verb check python checking for Python executable "python2" in the PATH gyp verb which failed Error: not found: python2 gyp verb which failed at getNotFoundError (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:13:12) gyp verb which failed at F (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:68:19) gyp verb which failed at E (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:80:29) gyp verb which failed at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:89:16 gyp verb which failed at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\index.js:42:5 gyp verb which failed at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\windows.js:36:5 gyp verb which failed at FSReqWrap.oncomplete (fs.js:152:21) gyp verb which failed python2 { Error: not found: python2 gyp verb which failed at getNotFoundError (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:13:12) gyp verb which failed at F (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:68:19) gyp verb which failed at E (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:80:29) gyp verb which failed at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:89:16 gyp verb which failed at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\index.js:42:5 gyp verb which failed at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\windows.js:36:5 gyp verb which failed at FSReqWrap.oncomplete (fs.js:152:21) gyp verb which failed stack: 'Error: not found: python2\n at getNotFoundError (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:13:12)\n at F (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:68:19)\n at E (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:80:29)\n at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:89:16\n at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\index.js:42:5\n at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\windows.js:36:5\n at FSReqWrap.oncomplete (fs.js:152:21)', gyp verb which failed code: 'ENOENT' } gyp verb check python checking for Python executable "python" in the PATH gyp verb which failed Error: not found: python gyp verb which failed at getNotFoundError (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:13:12) gyp verb which failed at F (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:68:19) gyp verb which failed at E (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:80:29) gyp verb which failed at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:89:16 gyp verb which failed at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\index.js:42:5 gyp verb which failed at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\windows.js:36:5 gyp verb which failed at FSReqWrap.oncomplete (fs.js:152:21) gyp verb which failed python { Error: not found: python gyp verb which failed at getNotFoundError (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:13:12) gyp verb which failed at F (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:68:19) gyp verb which failed at E (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:80:29) gyp verb which failed at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:89:16 gyp verb which failed at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\index.js:42:5 gyp verb which failed at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\windows.js:36:5 gyp verb which failed at FSReqWrap.oncomplete (fs.js:152:21) gyp verb which failed stack: 'Error: not found: python\n at getNotFoundError (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:13:12)\n at F (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:68:19)\n at E (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:80:29)\n at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:89:16\n at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\index.js:42:5\n at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\windows.js:36:5\n at FSReqWrap.oncomplete (fs.js:152:21)', gyp verb which failed code: 'ENOENT' } gyp verb could not find "python". checking python launcher gyp verb could not find "python". guessing location gyp verb ensuring that file exists: C:\Python27\python.exe gyp ERR! configure error gyp ERR! stack Error: Can't find Python executable "python", you can set the PYTHON env variable. gyp ERR! stack at PythonFinder.failNoPython (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\lib\configure.js:483:19) gyp ERR! stack at PythonFinder. (C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\lib\configure.js:508:16) gyp ERR! stack at C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\graceful-fs\polyfills.js:284:29 gyp ERR! stack at FSReqWrap.oncomplete (fs.js:152:21) gyp ERR! System Windows_NT 10.0.15063 gyp ERR! command "C:\Program Files\nodejs\node.exe" "C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\bin\node-gyp.js" "rebuild" "--verbose" "--libsass_ext=" "--libsass_cflags=" "--libsass_ldflags=" "--libsass_library=" gyp ERR! cwd C:\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass gyp ERR! node -v v8.1.4 gyp ERR! node-gyp -v v3.6.2 gyp ERR! not ok Build failed with error code: 1

There were some problems during the installation.

✓ New project folder created. ✗ Node modules not installed. Try running npm install manually. ✓ Bower components installed.

 

Once you've resolved the above issues, run foundation watch while inside the news1 folder.

Rafi Benkual about 2 years ago

 For some reason node_modules didn't install. You can delete the folder if it was created then run npm install to rebuild it.

Ivan Ortiz about 2 years ago

That's the message when I delete the folder npm-modules and write npm install.

C:\Users\ivano\npmhost\news1>npm install
WARN registry Unexpected warning for https://registry.npmjs.org/: Miscellaneous Warning EINTEGRITY: sha512-9jjUFbTPfEy3R/ad/2oNbKtW9Hgovl5O1FvFWKkKblNXoN/Oou6+9+KKohPK13Yc3/TyunyWhJp6gvRNR/PPAw== integrity checksum failed when using sha512: wanted sha512-9jjUFbTPfEy3R/ad/2oNbKtW9Hgovl5O1FvFWKkKblNXoN/Oou6+9+KKohPK13Yc3/TyunyWhJp6gvRNR/PPAw== but got sha1-EvlaMH1YNSB1oEkHuErIvpisAS8=. (8671 bytes)
WARN registry Using stale package data from https://registry.npmjs.org/ due to a request error during revalidation.
WARN registry Unexpected warning for https://registry.npmjs.org/: Miscellaneous Warning EINTEGRITY: sha512-MJTUg1kjuLeQCJ+ccE4Vpa6kKVXkPYJ2mOCQyUuKLcLQsdrMCpBPUi8qVE6+YuaJkozeA9NusTAw3hLr8Xe5EQ== integrity checksum failed when using sha512: wanted sha512-MJTUg1kjuLeQCJ+ccE4Vpa6kKVXkPYJ2mOCQyUuKLcLQsdrMCpBPUi8qVE6+YuaJkozeA9NusTAw3hLr8Xe5EQ== but got sha1-wZyd+aAocC1nhhI4SmVSQExjbRU=. (15621 bytes)
WARN registry Using stale package data from https://registry.npmjs.org/ due to a request error during revalidation.
WARN registry Unexpected warning for https://registry.npmjs.org/: Miscellaneous Warning EINTEGRITY: sha512-yJHVQEhyqPLUTgt9B83PXu6W3rx4MvvHvSUvToogpwoGDOUQ+yDrR0HRot+yOCdCO7u4hX3pWft6kWBBcqh0UA== integrity checksum failed when using sha512: wanted sha512-yJHVQEhyqPLUTgt9B83PXu6W3rx4MvvHvSUvToogpwoGDOUQ+yDrR0HRot+yOCdCO7u4hX3pWft6kWBBcqh0UA== but got sha1-UWbihkV/AzBgZL5Ul+jbsMPTIIM=. (11423 bytes)
registry Using stale package data from https://registry.npmjs.org/ due to a request error during revalidation.
WARN registry Unexpected warning for https://registry.npmjs.org/: Miscellaneous Warning EINTEGRITY: sha512-kKvNJn6Mm93gAczWVJg7wH+wGYWNrDHdWvpUmHyEsgCtIwwo3bqPtV4tR5tuPaUhTOo/kvhVwd8XwwOllGYkbg== integrity checksum failed when using sha512: wanted sha512-kKvNJn6Mm93gAczWVJg7wH+wGYWNrDHdWvpUmHyEsgCtIwwo3bqPtV4tR5tuPaUhTOo/kvhVwd8XwwOllGYkbg== but got sha1-iTMSr2myEj3vcfV4iQAWce6yyFM=. (8851 bytes)
WARN registry Using stale package data from https://registry.npmjs.org/ due to a request error during revalidation.
WARN registry Unexpected warning for https://registry.npmjs.org/: Miscellaneous Warning EINTEGRITY: sha512-D5JUjPyJbaJDkuAazpVnSfVkLlpeO3wDlPROTMLGKG1zMFNFRgrciKo1ltz/AzNTkqE0HzDx655QOL51N06how== integrity checksum failed when using sha512: wanted sha512-D5JUjPyJbaJDkuAazpVnSfVkLlpeO3wDlPROTMLGKG1zMFNFRgrciKo1ltz/AzNTkqE0HzDx655QOL51N06how== but got sha1-x6vpzIuHwLqodrGf3oP9RkeX44w=. (4087 bytes)
WARN registry Using stale package data from https://registry.npmjs.org/ due to a request error during revalidation.
WARN registry Unexpected warning for https://registry.npmjs.org/: Miscellaneous Warning EINTEGRITY: sha512-kKvNJn6Mm93gAczWVJg7wH+wGYWNrDHdWvpUmHyEsgCtIwwo3bqPtV4tR5tuPaUhTOo/kvhVwd8XwwOllGYkbg== integrity checksum failed when using sha512: wanted sha512-kKvNJn6Mm93gAczWVJg7wH+wGYWNrDHdWvpUmHyEsgCtIwwo3bqPtV4tR5tuPaUhTOo/kvhVwd8XwwOllGYkbg== but got sha1-iTMSr2myEj3vcfV4iQAWce6yyFM=. (8851 bytes)
WARN registry Using stale package data from https://registry.npmjs.org/ due to a request error during revalidation.
WARN registry Unexpected warning for https://registry.npmjs.org/: Miscellaneous Warning EINTEGRITY: sha512-oftTcaMu/EGrEIu904mWteKIv8vMuOgGYo7EhVJJN00R/EED9DCua/xxHRdYnKtcECzVg7xOWhflvJMnqcFZjw== integrity checksum failed when using sha512: wanted sha512-oftTcaMu/EGrEIu904mWteKIv8vMuOgGYo7EhVJJN00R/EED9DCua/xxHRdYnKtcECzVg7xOWhflvJMnqcFZjw== but got sha1-RJnt3NERDgshi6zy+n9/WfVcqAQ=. (52016 bytes)
WARN registry Using stale package data from https://registry.npmjs.org/ due to a request error during revalidation.
registry Unexpected warning for https://registry.npmjs.org/: Miscellaneous Warning EINTEGRITY: sha512-m+qzzcn7KUxEmd1gMbchF+Y2eIUbieUaxkWtptyHywrX0rE8QEYqPC07Vuy4Wm32/xE16NcdBctb8S0Xe/5IeQ== integrity checksum failed when using sha512: wanted sha512-m+qzzcn7KUxEmd1gMbchF+Y2eIUbieUaxkWtptyHywrX0rE8QEYqPC07Vuy4Wm32/xE16NcdBctb8S0Xe/5IeQ== but got sha1-No8lEtefnUb9/HE0mueHi7weuVw=. (25587 bytes)
WARN registry Using stale package data from https://registry.npmjs.org/ due to a request error during revalidation.

> phantomjs-prebuilt@2.1.14 install C:\Users\ivano\npmhost\news1\node_modules\gulp-uncss\node_modules\uncss\node_modules\phridge\node_modules\phantomjs-prebuilt
> node install.js

Considering PhantomJS found at C:\Users\ivano\AppData\Roaming\npm\phantomjs.CMD
Looks like an `npm install -g` on windows; skipping installed version.
Download already available at C:\Users\ivano\AppData\Local\Temp\phantomjs\phantomjs-2.1.1-windows.zip
Verified checksum of previously downloaded file
Extracting zip contents
Removing C:\Users\ivano\npmhost\news1\node_modules\gulp-uncss\node_modules\uncss\node_modules\phridge\node_modules\phantomjs-prebuilt\lib\phantom
Copying extracted folder C:\Users\ivano\AppData\Local\Temp\phantomjs\phantomjs-2.1.1-windows.zip-extract-1500483512758\phantomjs-2.1.1-windows -> C:\Users\ivano\npmhost\news1\node_modules\gulp-uncss\node_modules\uncss\node_modules\phridge\node_modules\phantomjs-prebuilt\lib\phantom
Writing location.js file
Done. Phantomjs binary available at C:\Users\ivano\npmhost\news1\node_modules\gulp-uncss\node_modules\uncss\node_modules\phridge\node_modules\phantomjs-prebuilt\lib\phantom\bin\phantomjs.exe

> node-sass@3.13.1 install C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass
> node scripts/install.js

Downloading binary from https://github.com/sass/node-sass/releases/download/v3.13.1/win32-x64-57_binding.node
Cannot download "https://github.com/sass/node-sass/releases/download/v3.13.1/win32-x64-57_binding.node":

HTTP error 404 Not Found

Hint: If github.com is not accessible in your location
      try setting a proxy via HTTP_PROXY, e.g.

      export HTTP_PROXY=http://example.com:1234

or configure npm proxy via

      npm config set proxy http://example.com:8080

> gifsicle@3.0.4 postinstall C:\Users\ivano\npmhost\news1\node_modules\gulp-imagemin\node_modules\imagemin\node_modules\imagemin-gifsicle\node_modules\gifsicle
> node lib/install.js

  √ gifsicle pre-build test passed successfully

> jpegtran-bin@3.2.0 postinstall C:\Users\ivano\npmhost\news1\node_modules\gulp-imagemin\node_modules\imagemin\node_modules\imagemin-jpegtran\node_modules\jpegtran-bin
> node lib/install.js

  √ jpegtran pre-build test passed successfully

> optipng-bin@3.1.4 postinstall C:\Users\ivano\npmhost\news1\node_modules\gulp-imagemin\node_modules\imagemin\node_modules\imagemin-optipng\node_modules\optipng-bin
> node lib/install.js

  √ optipng pre-build test passed successfully

> node-sass@3.13.1 postinstall C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass
> node scripts/build.js

Building: C:\Program Files\nodejs\node.exe C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\bin\node-gyp.js rebuild --verbose --libsass_ext= --libsass_cflags= --libsass_ldflags= --libsass_library=
gyp info it worked if it ends with ok
gyp verb cli [ 'C:\\Program Files\\nodejs\\node.exe',
gyp verb cli   'C:\\Users\\ivano\\npmhost\\news1\\node_modules\\gulp-sass\\node_modules\\node-sass\\node_modules\\node-gyp\\bin\\node-gyp.js',
gyp verb cli   'rebuild',
gyp verb cli   '--verbose',
gyp verb cli   '--libsass_ext=',
gyp verb cli   '--libsass_cflags=',
gyp verb cli   '--libsass_ldflags=',
gyp verb cli   '--libsass_library=' ]
gyp info using node-gyp@3.6.2
gyp info using node@8.1.4 | win32 | x64
gyp verb command rebuild []
gyp verb command clean []
gyp verb clean removing "build" directory
gyp verb command configure []
gyp verb check python checking for Python executable "python2" in the PATH
gyp verb `which` failed Error: not found: python2
gyp verb `which` failed     at getNotFoundError (C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:13:12)
gyp verb `which` failed     at F (C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:68:19)
gyp verb `which` failed     at E (C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:80:29)
gyp verb `which` failed     at C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:89:16
gyp verb `which` failed     at C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\index.js:42:5
gyp verb `which` failed     at C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\windows.js:36:5
gyp verb `which` failed     at FSReqWrap.oncomplete (fs.js:152:21)
gyp verb `which` failed  python2 { Error: not found: python2
gyp verb `which` failed     at getNotFoundError (C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:13:12)
gyp verb `which` failed     at F (C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:68:19)
gyp verb `which` failed     at E (C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:80:29)
gyp verb `which` failed     at C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:89:16
gyp verb `which` failed     at C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\index.js:42:5
gyp verb `which` failed     at C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\windows.js:36:5
gyp verb `which` failed     at FSReqWrap.oncomplete (fs.js:152:21)
gyp verb `which` failed   stack: 'Error: not found: python2\n    at getNotFoundError (C:\\Users\\ivano\\npmhost\\news1\\node_modules\\gulp-sass\\node_modules\\node-sass\\node_modules\\node-gyp\\node_modules\\which\\which.js:13:12)\n    at F (C:\\Users\\ivano\\npmhost\\news1\\node_modules\\gulp-sass\\node_modules\\node-sass\\node_modules\\node-gyp\\node_modules\\which\\which.js:68:19)\n    at E (C:\\Users\\ivano\\npmhost\\news1\\node_modules\\gulp-sass\\node_modules\\node-sass\\node_modules\\node-gyp\\node_modules\\which\\which.js:80:29)\n    at C:\\Users\\ivano\\npmhost\\news1\\node_modules\\gulp-sass\\node_modules\\node-sass\\node_modules\\node-gyp\\node_modules\\which\\which.js:89:16\n    at C:\\Users\\ivano\\npmhost\\news1\\node_modules\\gulp-sass\\node_modules\\node-sass\\node_modules\\node-gyp\\node_modules\\which\\node_modules\\isexe\\index.js:42:5\n    at C:\\Users\\ivano\\npmhost\\news1\\node_modules\\gulp-sass\\node_modules\\node-sass\\node_modules\\node-gyp\\node_modules\\which\\node_modules\\isexe\\windows.js:36:5\n    at FSReqWrap.oncomplete (fs.js:152:21)',
gyp verb `which` failed   code: 'ENOENT' }
gyp verb check python checking for Python executable "python" in the PATH
gyp verb `which` failed Error: not found: python
gyp verb `which` failed     at getNotFoundError (C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:13:12)
gyp verb `which` failed     at F (C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:68:19)
gyp verb `which` failed     at E (C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:80:29)
gyp verb `which` failed     at C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:89:16
gyp verb `which` failed     at C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\index.js:42:5
gyp verb `which` failed     at C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\windows.js:36:5
gyp verb `which` failed     at FSReqWrap.oncomplete (fs.js:152:21)
gyp verb `which` failed  python { Error: not found: python
gyp verb `which` failed     at getNotFoundError (C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:13:12)
gyp verb `which` failed     at F (C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:68:19)
gyp verb `which` failed     at E (C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:80:29)
gyp verb `which` failed     at C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\which.js:89:16
gyp verb `which` failed     at C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\index.js:42:5
gyp verb `which` failed     at C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\which\node_modules\isexe\windows.js:36:5
gyp verb `which` failed     at FSReqWrap.oncomplete (fs.js:152:21)
gyp verb `which` failed   stack: 'Error: not found: python\n    at getNotFoundError (C:\\Users\\ivano\\npmhost\\news1\\node_modules\\gulp-sass\\node_modules\\node-sass\\node_modules\\node-gyp\\node_modules\\which\\which.js:13:12)\n    at F (C:\\Users\\ivano\\npmhost\\news1\\node_modules\\gulp-sass\\node_modules\\node-sass\\node_modules\\node-gyp\\node_modules\\which\\which.js:68:19)\n    at E (C:\\Users\\ivano\\npmhost\\news1\\node_modules\\gulp-sass\\node_modules\\node-sass\\node_modules\\node-gyp\\node_modules\\which\\which.js:80:29)\n    at C:\\Users\\ivano\\npmhost\\news1\\node_modules\\gulp-sass\\node_modules\\node-sass\\node_modules\\node-gyp\\node_modules\\which\\which.js:89:16\n    at C:\\Users\\ivano\\npmhost\\news1\\node_modules\\gulp-sass\\node_modules\\node-sass\\node_modules\\node-gyp\\node_modules\\which\\node_modules\\isexe\\index.js:42:5\n    at C:\\Users\\ivano\\npmhost\\news1\\node_modules\\gulp-sass\\node_modules\\node-sass\\node_modules\\node-gyp\\node_modules\\which\\node_modules\\isexe\\windows.js:36:5\n    at FSReqWrap.oncomplete (fs.js:152:21)',
gyp verb `which` failed   code: 'ENOENT' }
gyp verb could not find "python". checking python launcher
gyp verb could not find "python". guessing location
gyp verb ensuring that file exists: C:\Python27\python.exe
gyp ERR! configure error
gyp ERR! stack Error: Can't find Python executable "python", you can set the PYTHON env variable.
gyp ERR! stack     at PythonFinder.failNoPython (C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\lib\configure.js:483:19)
gyp ERR! stack     at PythonFinder.<anonymous> (C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\lib\configure.js:508:16)
gyp ERR! stack     at C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass\node_modules\node-gyp\node_modules\graceful-fs\polyfills.js:284:29
gyp ERR! stack     at FSReqWrap.oncomplete (fs.js:152:21)
gyp ERR! System Windows_NT 10.0.15063
gyp ERR! command "C:\\Program Files\\nodejs\\node.exe" "C:\\Users\\ivano\\npmhost\\news1\\node_modules\\gulp-sass\\node_modules\\node-sass\\node_modules\\node-gyp\\bin\\node-gyp.js" "rebuild" "--verbose" "--libsass_ext=" "--libsass_cflags=" "--libsass_ldflags=" "--libsass_library="
gyp ERR! cwd C:\Users\ivano\npmhost\news1\node_modules\gulp-sass\node_modules\node-sass
gyp ERR! node -v v8.1.4
gyp ERR! node-gyp -v v3.6.2
gyp ERR! not ok
Build failed with error code: 1
npm WARN Error: EPERM: operation not permitted, scandir 'C:\Users\ivano\npmhost\news1\node_modules\fsevents\node_modules\getpass\node_modules'
npm WARN  { Error: EPERM: operation not permitted, scandir 'C:\Users\ivano\npmhost\news1\node_modules\fsevents\node_modules\getpass\node_modules'
npm WARN   stack: 'Error: EPERM: operation not permitted, scandir \'C:\\Users\\ivano\\npmhost\\news1\\node_modules\\fsevents\\node_modules\\getpass\\node_modules\'',
npm WARN   errno: -4048,
npm WARN   code: 'EPERM',
npm WARN   syscall: 'scandir',
npm WARN   path: 'C:\\Users\\ivano\\npmhost\\news1\\node_modules\\fsevents\\node_modules\\getpass\\node_modules' }
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! node-sass@3.13.1 postinstall: `node scripts/build.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the node-sass@3.13.1 postinstall script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\ivano\AppData\Roaming\npm-cache\_logs\2017-07-19T16_58_46_864Z-debug.log

Ivan Ortiz about 2 years ago

I delete all Node JS and npm as says here:

 https://stackoverflow.com/questions/38602808/uninstall-node-js-windows-10

And the I reinstall node, gulp, bower and foundation-cli. And shows the same error. Then i write npm install
as says Rafi Benkual and it works.

Ivan Ortiz about 2 years ago

The problem now is foundation watch.

 

Show this error in the Command Panel:


[14:15:37] Using gulpfile ~\npmhost\hotel1\gulpfile.js
[14:15:37] Starting 'sass'...
[14:15:37] 'sass' errored after 54 ms
[14:15:37] Error: Node Sass does not yet support your current environment: Windows 64-bit with Unsupported runtime (57)
For more information on which environments are supported please see:
https://github.com/sass/node-sass/releases/tag/v3.13.1
    at module.exports (C:\Users\ivano\npmhost\hotel1\node_modules\gulp-sass\node_modules\node-sass\lib\binding.js:13:13)
    at Object.<anonymous> (C:\Users\ivano\npmhost\hotel1\node_modules\gulp-sass\node_modules\node-sass\lib\index.js:14:35)
    at Module._compile (module.js:569:30)
    at Object.Module._extensions..js (module.js:580:10)
    at Module.load (module.js:503:32)
    at tryModuleLoad (module.js:466:12)
    at Function.Module._load (module.js:458:3)
    at Module.require (module.js:513:17)
    at require (internal/module.js:11:18)
    at Object.<anonymous> (C:\Users\ivano\npmhost\hotel1\node_modules\gulp-sass\index.js:187:21)
Error: foundation-sites-template@1.0.0 start: `gulp`
Exit status 1
    at EventEmitter.<anonymous> (C:\Users\ivano\AppData\Roaming\npm\node_modules\foundation-cli\node_modules\npm\lib\utils\lifecycle.js:217:16)
    at emitTwo (events.js:125:13)
    at EventEmitter.emit (events.js:213:7)
    at ChildProcess.<anonymous> (C:\Users\ivano\AppData\Roaming\npm\node_modules\foundation-cli\node_modules\npm\lib\utils\spawn.js:24:14)
    at emitTwo (events.js:125:13)
    at ChildProcess.emit (events.js:213:7)
    at maybeClose (internal/child_process.js:897:16)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:208:5)

Ivan Ortiz about 2 years ago

OK I need to install node 6 instead of node 8.

https://github.com/sass/node-sass/issues/2042