Menu icon Foundation
Upgrade to 6.4

Hello, I need some help on how to upgrade from 6.3 to 6.4. I ran "foundation update", got message "Nothing to update. You're good!", but when checking bower_components/foundation-sites/ bower.json I still see version 6.3.1

Thank you. 

upgradeUpdate

Hello, I need some help on how to upgrade from 6.3 to 6.4. I ran "foundation update", got message "Nothing to update. You're good!", but when checking bower_components/foundation-sites/ bower.json I still see version 6.3.1

Thank you. 

Rafi Benkual about 2 years ago

You'll want to change the version number in the bower.json to 6.4

"dependencies": {
    "foundation-sites": "~6.4.0",

then run bower update

Alex K about 2 years ago

Hello and thank you for your help. I ran bower update, this part was successful. Now when I'm trying to run "foundation watch" getting following errors. Please see attached image. Thank you

 

 

Ash Williams about 2 years ago

I have the same errors after trying to update to 6.4.*......any ideas?? Thanks!

Joel Majors about 2 years ago

Has anyone solved this problem? I'm really looking forward to not floundering on this any longer.

Joel Majors about 2 years ago

I discovered the answer after I RTFM. In the 6.4 migration notes it says:

  1. The underlying file for the responsive accordion tabs plugin has changed. If you are upgrading an old ZURB stack project you will need to change the reference to foundation-sites/js/foundation.zf.responsiveAccordionTabs.js to reference foundation-sites/js/foundation.responsiveAccordionTabs.js instead.