Menu icon Foundation
Orbit resize slide count problem

I encountered a problem with the orbit slider and I coulndn't find any posts an this.

When the window is resized during orbit changing slides then orbit is broken: When you wait or navigate with the arrow buttons then at some point there will follow an empty slide, auto play stops and you can't navigate anymore (arrows or bullets).

You can try this out even in the official orbit documentation:

http://foundation.zurb.com/sites/docs/orbit.html

Just view an auto played orbit, resize window in the moment auf slide change (or all the time if you are too slow ;) and navigate through the slides. At some point orbit will be blank and stops working. No js errors.

Has someone a solution or workaround for this? I tried many different things with no success.

Orbitresizeslidecount

I encountered a problem with the orbit slider and I coulndn't find any posts an this.

When the window is resized during orbit changing slides then orbit is broken: When you wait or navigate with the arrow buttons then at some point there will follow an empty slide, auto play stops and you can't navigate anymore (arrows or bullets).

You can try this out even in the official orbit documentation:

http://foundation.zurb.com/sites/docs/orbit.html

Just view an auto played orbit, resize window in the moment auf slide change (or all the time if you are too slow ;) and navigate through the slides. At some point orbit will be blank and stops working. No js errors.

Has someone a solution or workaround for this? I tried many different things with no success.

Corbin K over 2 years ago

Hi Andy,

Have you by chance found a solution for this issue?

I am experiencing the exact same problem.

Corbin K over 2 years ago

In case you haven't found a solution. I did find a few threads on GitHub talking about this issue. They have merged in a fix earlier this month.

 

More specifically this is what was updated in the foundation.orbit.js file.

https://github.com/zurb/foundation-sites/pull/9881/files

Andy Mey over 2 years ago

Thanks Corbin!

The project I was working on is still in development, so I saved this issue for later. ;)

This fix works great! Thanks for your help!

Mark Z over 2 years ago

Thanks for this, I was experiencing this issue too and seems to have fixed it :)