Menu icon Foundation
Foundation Email: Variables with slashes aren't working as link href

Hi!

 

This is my first post on this forum, looking forward to getting involved!

I'm using Foundation for Emails 2 and building my first templates.

I'm running into a problem though. I'm sending in a variable to use for a hyperlink href, it's an activation link. something like:

activation_url: "{{activation_url}}"

And the value coming in something like "https://my-site.com/longer/url"

If I just print out the variable on the page, it's showing that it came through properly. However, if I try and use it
like <a href="{{activation_url}}">my link</a>, it is not working. I've tested it a bunch, and it seems
to be the slash characters that are throwing it off.

How can I use an coming url with slashes as an href on an anchor tab in Foundation for emails 2?

Thanks in advance!

Todd

variablesemailslashes

Hi!

 

This is my first post on this forum, looking forward to getting involved!

I'm using Foundation for Emails 2 and building my first templates.

I'm running into a problem though. I'm sending in a variable to use for a hyperlink href, it's an activation link. something like:

activation_url: "{{activation_url}}"

And the value coming in something like "https://my-site.com/longer/url"

If I just print out the variable on the page, it's showing that it came through properly. However, if I try and use it
like <a href="{{activation_url}}">my link</a>, it is not working. I've tested it a bunch, and it seems
to be the slash characters that are throwing it off.

How can I use an coming url with slashes as an href on an anchor tab in Foundation for emails 2?

Thanks in advance!

Todd
Corey Schaaf over 2 years ago

Todd are you calling this information from a .yml file in the data folder or are you making variables on the page and pulling them in? 

kopamam over 2 years ago

d have tough moments it’s amazing to be here. Last year was tough for me because it takes a while to get back to my level.

federervsnadallive-stream.us