Menu icon Foundation
Buttons are Not Displaying Properly

Hey,

Wondering why my buttons sometimes look like they're missing padding.  There's should be 4 buttons displaying but one doesnt show and the other lacks padding.

Here's the code I'm using.  This seems to be an issue with alomost every email I create.

 

 <row>
    <columns small="12" large="6">
      <center><img src="http://www2.tracktik.com/l/150101/2016-11-30/8q387/150101/25860/contracting.jpg" alt="" width="231" height="233"></center>
      <spacer size="20"></spacer>
      <h3 class="text-center">Contracting <br>&amp; Invoicing</h3>
      <p class="text-center">Always on Service<br>Measure Profitability</p>
      <spacer size="20"></spacer>
      <center><button href="http://www2.tracktik.com/contracting_invoicing_brochure">Full Features</button></center>
    </columns>
    <columns small="12" large="6">
      <center><img src="http://www2.tracktik.com/l/150101/2016-11-30/8q385/150101/25856/scheduling.jpg" alt="" width="231" height="233"></center>
      <spacer size="20"></spacer>
      <h3 class="text-center">Scheduling <br>&amp; Attendance</h3>
      <p class="text-center">Always on Schedule<br>Right Guard, Right Site</p>
      <spacer size="20"></spacer>
      <center><button href="http://www2.tracktik.com/scheduling_brochure">Full Features</button></center>
    </columns>
  </row>
  <row>
    <columns small="12" large="6">
      <spacer size="30"></spacer>
      <center><img src="http://www2.tracktik.com/l/150101/2016-11-30/8q387/150101/25860/contracting.jpg" alt="" width="231" height="233"></center>
      <spacer size="20"></spacer>
      <h3 class="text-center">Business <br>Intelligence</h3>
      <p class="text-center">Always on Target<br>Data Driven Decisions</p>
      <spacer size="20"></spacer>
      <center><button href="http://www2.tracktik.com/BI_brochure">Full Features</button></center>
      <spacer size="30"></spacer>
    </columns>
    <columns small="12" large="6">
      <spacer size="30"></spacer>
      <center><img src="http://www2.tracktik.com/l/150101/2016-11-30/8q385/150101/25856/scheduling.jpg" alt="" width="231" height="233"></center>
      <spacer size="20"></spacer>
      <h3 class="text-center">Payroll &amp; <br>Accounting Integrations</h3>
      <p class="text-center">Always on Budget<br>Accuracy, Efficiency, Profitability</p>
      <spacer size="20"></spacer>
      <center><button href="http://www2.tracktik.com/payroll_accounting_brochure">Full Features</button></center>
      <spacer size="30"></spacer>
    </columns>
  </row>

Thanks for the help.

buttons

Hey,

Wondering why my buttons sometimes look like they're missing padding.  There's should be 4 buttons displaying but one doesnt show and the other lacks padding.

Here's the code I'm using.  This seems to be an issue with alomost every email I create.

 

 <row>
    <columns small="12" large="6">
      <center><img src="http://www2.tracktik.com/l/150101/2016-11-30/8q387/150101/25860/contracting.jpg" alt="" width="231" height="233"></center>
      <spacer size="20"></spacer>
      <h3 class="text-center">Contracting <br>&amp; Invoicing</h3>
      <p class="text-center">Always on Service<br>Measure Profitability</p>
      <spacer size="20"></spacer>
      <center><button href="http://www2.tracktik.com/contracting_invoicing_brochure">Full Features</button></center>
    </columns>
    <columns small="12" large="6">
      <center><img src="http://www2.tracktik.com/l/150101/2016-11-30/8q385/150101/25856/scheduling.jpg" alt="" width="231" height="233"></center>
      <spacer size="20"></spacer>
      <h3 class="text-center">Scheduling <br>&amp; Attendance</h3>
      <p class="text-center">Always on Schedule<br>Right Guard, Right Site</p>
      <spacer size="20"></spacer>
      <center><button href="http://www2.tracktik.com/scheduling_brochure">Full Features</button></center>
    </columns>
  </row>
  <row>
    <columns small="12" large="6">
      <spacer size="30"></spacer>
      <center><img src="http://www2.tracktik.com/l/150101/2016-11-30/8q387/150101/25860/contracting.jpg" alt="" width="231" height="233"></center>
      <spacer size="20"></spacer>
      <h3 class="text-center">Business <br>Intelligence</h3>
      <p class="text-center">Always on Target<br>Data Driven Decisions</p>
      <spacer size="20"></spacer>
      <center><button href="http://www2.tracktik.com/BI_brochure">Full Features</button></center>
      <spacer size="30"></spacer>
    </columns>
    <columns small="12" large="6">
      <spacer size="30"></spacer>
      <center><img src="http://www2.tracktik.com/l/150101/2016-11-30/8q385/150101/25856/scheduling.jpg" alt="" width="231" height="233"></center>
      <spacer size="20"></spacer>
      <h3 class="text-center">Payroll &amp; <br>Accounting Integrations</h3>
      <p class="text-center">Always on Budget<br>Accuracy, Efficiency, Profitability</p>
      <spacer size="20"></spacer>
      <center><button href="http://www2.tracktik.com/payroll_accounting_brochure">Full Features</button></center>
      <spacer size="30"></spacer>
    </columns>
  </row>

Thanks for the help.

Rafi Benkual almost 3 years ago

For emails, the href needs to have a valid url for the button to render properly in a few clients.