Menu icon Foundation
Requring external module babel-register slow

FFE is working perfectly, except for a frustratingly long delay during the step:

"Requiring external module babel-register"

It takes anywhere from 30 seconds to as long as 4 minutes to complete that step. Have tried it on 2 different systems in 2 totally different locations/networks with same results. No error messages, just slow. All subsequent steps run lightning fast. Internet connection appears to be running fast at (90Mbps+).

I'm totally new to node, gulp, etc. Any ideas why this delay occurs, or even just an explanation of what exactly is happening during that step so that I can narrow down the problem? Thanks!

babel-registerBabelexternal module

FFE is working perfectly, except for a frustratingly long delay during the step:

"Requiring external module babel-register"

It takes anywhere from 30 seconds to as long as 4 minutes to complete that step. Have tried it on 2 different systems in 2 totally different locations/networks with same results. No error messages, just slow. All subsequent steps run lightning fast. Internet connection appears to be running fast at (90Mbps+).

I'm totally new to node, gulp, etc. Any ideas why this delay occurs, or even just an explanation of what exactly is happening during that step so that I can narrow down the problem? Thanks!

Corey Schaaf about 3 years ago

Out of curiosity, how many files do you have in your pages directory that are trying to be inlined? Also, are you using foundation build or foundation watch? Is there a difference in the time for either of them? Also, are you IOS, PC? 

Evan Wiegand about 3 years ago

Just 1 file in 'pages'; typically 10-15 in 'partials'. I just ran tests with 1 partial vs 30 partials and neither had any effect for better or worse. I normally run 'build'. Tried 'watch' and still got same results. 

OSX Yosemite on iMac 2011, also tried a mac mini 2015. 

To clarify, the time it takes the babel-register step is inconsistent within the SAME project. It randomly varies from about 20-30s to several mins on each run, even if all the project files stay exactly the same. 

Interestingly, today it's averaging 20-30s, which I can certainly live with. But I've seen some people's screenshots from the terminal indicating only 1-2 seconds. What's normal? 

Thanks!

 

Scott Bickell almost 3 years ago

Ugh! I have this exact same issue on two different computers. I've been living with it for months! I really wish I knew how to fix it. Major slowdown in my productivity. Anybody know how to fix this?

mxeise over 2 years ago

+1

Scott Bickell over 2 years ago

This situation has improved greatly for me using node 7.4.0 and npm 4.1.2 on MacOS.

Still takes a few seconds (less than 10), but that's better than 45.

Evan Wiegand over 2 years ago

FINALLY! Thank you Scott! Got me down from ~4 mins to a speedy 5 secs!