Menu icon Foundation
Abide v6 <textarea> field required validation failing when shouldn't

Abide is firing the required validation error when a value is supplied to a <textarea required ... </textarea> field.

<div class="row">

<div class="small-12 columns">    

<label>Message

<textarea required name="message" placeholder="Your message..." rows="4" aria-describedby="messageHelpText" /><?php echo ($message ? $message : ''); ?></textarea>

<span class="form-error">Message is required.</span>

</label>

<p class="help-text" id="messageHelpText">Message help text here.</p>

</div>

</div>

Abide v6 form validation screenshot

abidetextarea

Abide is firing the required validation error when a value is supplied to a <textarea required ... </textarea> field.

<div class="row">

<div class="small-12 columns">    

<label>Message

<textarea required name="message" placeholder="Your message..." rows="4" aria-describedby="messageHelpText" /><?php echo ($message ? $message : ''); ?></textarea>

<span class="form-error">Message is required.</span>

</label>

<p class="help-text" id="messageHelpText">Message help text here.</p>

</div>

</div>

Abide v6 form validation screenshot

This post has been closed. No new replies can be added.

Jay Todtenbier over 3 years ago

This appears to be a bug from Foundation 6.0.3 (resolved in current release) which Yetti seems to be currently installing (at least as of 5/30/16) rather than the current Foundation 6.3.x version.