Menu icon Foundation
Using jQuery 1.10.2 with Foundation 5

I will be using Foundation 5 ( I'm looking at the switch from Bootstrap 3.x ) in WordPress projects. The issue is that WordPress itself ships with a version of jQuery ( currently 1.10.2 ) and it is not best practice in WordPress to load other versions of jQuery ( see for example this post by Pippin: http://pippinsplugins.com/why-loading-your-own-jquery-is-irresponsible/ ).

I just wanted to check therefore that all features of Foundation 5 will work when using jQuery 1.10.2, and that the only difference with jQuery 2.x is that is drops support (and therefore is lighter) for older versions of IE?

Can anyone confirm this, please?

Thanks for your time, Andrew.

wordpressjquery

I will be using Foundation 5 ( I'm looking at the switch from Bootstrap 3.x ) in WordPress projects. The issue is that WordPress itself ships with a version of jQuery ( currently 1.10.2 ) and it is not best practice in WordPress to load other versions of jQuery ( see for example this post by Pippin: http://pippinsplugins.com/why-loading-your-own-jquery-is-irresponsible/ ).

I just wanted to check therefore that all features of Foundation 5 will work when using jQuery 1.10.2, and that the only difference with jQuery 2.x is that is drops support (and therefore is lighter) for older versions of IE?

Can anyone confirm this, please?

Thanks for your time, Andrew.

Andrew Brown almost 6 years ago

Is there anyone can comment on this, please?

Jake Wilson almost 6 years ago

I'd also be interested in knowing the answer to this.

Andrew Chilcott almost 6 years ago

I am currently using F5.0.2 with JQuery 1.10.2 with no problems whatsoever

pixeline over 5 years ago

I am also using ZF5.0.2 with jquery 1.10.2 but, in my case, the tabs don't work in IE8. If you are not using jquery2 because you want to keep supporting IE8, i suggest you stay on ZF3.