Menu icon Foundation
You don't appear to be in a Foundation project folder.

So, I've been working on a site for ages using the zurb template. 

Every time I work on it I go into the site folder and type "foundation watch" and it watches for changes and runs the browsersync server. 

Today I went into the folder and types "foundation watch" and I got "You don't appear to be in a Foundation project folder."

Since I'm using Panini, etc.. this basically means I can't do any work on my site. 

I don't remember changing anything on the site itself. The only thin I have done is use bower to install a datepicker into "bower_components". But I haven't plugged that into the site yet and that shouldn't have broken anything, right? 

I may have updated node or npm, but I don't remember doing so. I think both versions I have are from Nov 2015 and I haven't messed with them.

Foundation cli v = 2.1.0

Node = 4.2.2

Npm = 3.5.1

It's pretty urgent that I can get to work on the site again! 

Any help/ideas? 

 

foundation clifoundation watchF6Command Line

So, I've been working on a site for ages using the zurb template. 

Every time I work on it I go into the site folder and type "foundation watch" and it watches for changes and runs the browsersync server. 

Today I went into the folder and types "foundation watch" and I got "You don't appear to be in a Foundation project folder."

Since I'm using Panini, etc.. this basically means I can't do any work on my site. 

I don't remember changing anything on the site itself. The only thin I have done is use bower to install a datepicker into "bower_components". But I haven't plugged that into the site yet and that shouldn't have broken anything, right? 

I may have updated node or npm, but I don't remember doing so. I think both versions I have are from Nov 2015 and I haven't messed with them.

Foundation cli v = 2.1.0

Node = 4.2.2

Npm = 3.5.1

It's pretty urgent that I can get to work on the site again! 

Any help/ideas? 

 

Shoaib Iqbal over 3 years ago

Hi, can you post your directory structure? can you check if there are any files missing, compare it to newly downloaded files.

bill over 3 years ago

Thanks, but I worked it out. 

Turned out that the package.json file had somehow been deleted. Restoring that seems to have fixed the issue. 

Must have been user error on our end (probably me!)