Menu icon Foundation
Foundation watch errors

I have recently upgraded foundation-cli to version 6. When I create a new project, I get following warnings/errors

 

[akya@quady test] $ foundation new
(node:3923) fs: re-evaluating native module sources is not supported. If you are using the graceful-fs module, please update it to a more recent version.

Then 100s of line of stack trace and at the end

You're all set!

 ✓ New project folder created.
 ✓ Node modules installed.
 ✓ Bower components installed.

Now run foundation watch while inside the new folder.

When I run that, I get

akya@quady test] $ cd new/
[akya@quady new] $ foundation watch
(node:4217) fs: re-evaluating native module sources is not supported. If you are using the graceful-fs module, please update it to a more recent version.

> foundation-sites-template@1.0.0 start /media/Data/Website/V 5.0 (2015-16)/local/test/new
> gulp

(node:4226) fs: re-evaluating native module sources is not supported. If you are using the graceful-fs module, please update it to a more recent version.
[19:56:04] Using gulpfile /media/Data/Website/V 5.0 (2015-16)/local/test/new/gulpfile.js
[19:56:04] Starting 'sass'...
(node) v8::ObjectTemplate::Set() with non-primitive values is deprecated
(node) and will stop working in the next major release.

But looks like it's working. I am not sure about the stack trace and other errors that are popping up. Am I good to test the actual css and new stuff in 6?

watch

I have recently upgraded foundation-cli to version 6. When I create a new project, I get following warnings/errors

 

[akya@quady test] $ foundation new
(node:3923) fs: re-evaluating native module sources is not supported. If you are using the graceful-fs module, please update it to a more recent version.

Then 100s of line of stack trace and at the end

You're all set!

 ✓ New project folder created.
 ✓ Node modules installed.
 ✓ Bower components installed.

Now run foundation watch while inside the new folder.

When I run that, I get

akya@quady test] $ cd new/
[akya@quady new] $ foundation watch
(node:4217) fs: re-evaluating native module sources is not supported. If you are using the graceful-fs module, please update it to a more recent version.

> foundation-sites-template@1.0.0 start /media/Data/Website/V 5.0 (2015-16)/local/test/new
> gulp

(node:4226) fs: re-evaluating native module sources is not supported. If you are using the graceful-fs module, please update it to a more recent version.
[19:56:04] Using gulpfile /media/Data/Website/V 5.0 (2015-16)/local/test/new/gulpfile.js
[19:56:04] Starting 'sass'...
(node) v8::ObjectTemplate::Set() with non-primitive values is deprecated
(node) and will stop working in the next major release.

But looks like it's working. I am not sure about the stack trace and other errors that are popping up. Am I good to test the actual css and new stuff in 6?

Rafi Benkual about 3 years ago

I haven't seen those errors before. (I'm assuming you un-installed the old CLI) I'd probably uninstall and reinstall the CLI 

From the docs:

If you already have the Foundation 5 CLI on your machine, you will only be able to access one of the commands, depending on how your command line environment is configured.

If you want to remove the old CLI, run gem uninstall foundation. After testing this new CLI, if you want to go back to the old CLI, run npm uninstall foundation-cli --global.