Menu icon Foundation
Foundation & Terminal Issues

I just updated foundation in Terminal, and it now says Successfully installed foundation-1.0.4. I used to see this when typing foundation new:

 

... and now when I type foundation new, Terminal responds: ERROR: "foundation new" was called with no arguments.

 

I can add the project name ('foundation new MyProject'), but I don't get the option to choose a site, app, etc., nor with the Zurb/handlebar option, either. Why am I not seeing that? Have I "upgraded" to an old version by mistake? Where did those options go? 

I'm a bit of a Terminal newbie, so thanks in advance for any help!

Foundationterminalinstall

I just updated foundation in Terminal, and it now says Successfully installed foundation-1.0.4. I used to see this when typing foundation new:

 

... and now when I type foundation new, Terminal responds: ERROR: "foundation new" was called with no arguments.

 

I can add the project name ('foundation new MyProject'), but I don't get the option to choose a site, app, etc., nor with the Zurb/handlebar option, either. Why am I not seeing that? Have I "upgraded" to an old version by mistake? Where did those options go? 

I'm a bit of a Terminal newbie, so thanks in advance for any help!

Rafi Benkual over 3 years ago

Interesting - so you are not getting the arrow option?

Are you on a Mac or Windows?

Does it still create a project?

Rafi Benkual over 3 years ago

Actually - it does look like the old CLI

The new one is 

SO there are instructions here how to un-install and re-install 

If you already have the Foundation 5 CLI on your machine, you will only be able to access one of the commands, depending on how your command line environment is configured.

If you want to remove the old CLI, run gem uninstall foundation. After testing this new CLI, if you want to go back to the old CLI, run npm uninstall foundation-cli --global.

The install from http://foundation.zurb.com/sites/docs/installation.html

Rob T over 3 years ago

That was it, exactly--I had the old CLI installed as well. Thanks so much, Rafi!