Menu icon Foundation
Zurb Template: Which version of panini?

Why does zurb template's package.json reference ""panini": "^1.0.0"," when the current version in the repo is 1.2.0?

https://github.com/zurb/panini

I'm having all kinds of problems getting proper build and watch with panini, so I did an "npm update panini" to get the latest. Didn't seem to help much, still have inconsistent problems that I'm trying to debug, but it made me wonder why the template is still referring to an older version, and if it should be. Is panini 1.0.0 or 1.2.0 the one to use with zurb template? I want to know what zurb is using and and what issues you're having (if any), then I'm going to start over with a fresh install.

Thx.

ZURB Templatepanini

Why does zurb template's package.json reference ""panini": "^1.0.0"," when the current version in the repo is 1.2.0?

https://github.com/zurb/panini

I'm having all kinds of problems getting proper build and watch with panini, so I did an "npm update panini" to get the latest. Didn't seem to help much, still have inconsistent problems that I'm trying to debug, but it made me wonder why the template is still referring to an older version, and if it should be. Is panini 1.0.0 or 1.2.0 the one to use with zurb template? I want to know what zurb is using and and what issues you're having (if any), then I'm going to start over with a fresh install.

Thx.

Rafi Benkual almost 4 years ago

Not sure what issues you're having?

On the update:

In your package.json "panini": "^1.0.0",
this syntax means the the middle number to be bumped

Typically npm update checks this file and updates anything it has a newer version for

But you can also force it by running "npm install panini --save-dev"

Mark Hair almost 4 years ago

Hey Rafi,

Thanks for your answer to the above.

The reason I wasn't explicit is there have just been so many problems, and they've been very confusing to sort out. The thing that is still not happening for me with the current gulpfile.js, is not copying/compiling certain js files in src/assets/js to dist/assets/js. I have put the vendor folder (with jquery.js for the reason of complaints by dev tools of missing js files) and holderjs folder (for client-side generation of placeholder images) and owl-carousel folder in src/assets/js. I do "foundation watch" However, unless I manually move these src folders to dist/assets/js, none of the components work (with associated complaints about missing files in chrome dev tools). I've changed the lines below but it didn't help.

So what statements are necessary in the gulpfile to affect this? Thx.

  //'src/assets/js/**/!(app).js',
  //'src/assets/js/app.js'
    'src/assets/js/**/*.js'