Menu icon Foundation
Foundation CLI on Windows 8 - Not Working

I installed Foundation 6 via the command "npm install --global foundation-cli" on a Windows 8 box, and all seemed to go fine (see attached screen capture).

When I ran "Foundation New", the command window just hung, nothing happened. I then tried "Foundation -v" and it didn't recognize what that meant. In the attached screenshot, you can see I entered it correctly, but then I am returned a list of approved switches.

If I did "Foundation --version" it returned "2.0.2" which seems correct, but that doesn't match any of the documented switches, so not sure why "--version" worked.

I have uninstalled and reinstalled without success. What am I doing wrong?

Thanks
Steve

Foundation error

Capture

cli

I installed Foundation 6 via the command "npm install --global foundation-cli" on a Windows 8 box, and all seemed to go fine (see attached screen capture).

When I ran "Foundation New", the command window just hung, nothing happened. I then tried "Foundation -v" and it didn't recognize what that meant. In the attached screenshot, you can see I entered it correctly, but then I am returned a list of approved switches.

If I did "Foundation --version" it returned "2.0.2" which seems correct, but that doesn't match any of the documented switches, so not sure why "--version" worked.

I have uninstalled and reinstalled without success. What am I doing wrong?

Thanks
Steve

Foundation error

Capture
Steve Valet over 3 years ago

UPDATE: Fixed this by reinstalling NodeJS and Foundation together. Separately didn't seem to work, only when I removed both, then reinstalled.

Steve