Menu icon Foundation
Install Foundation CLI

Hello to everyone!
Can't install foundation-cli (don't know how to check this installed or not) or create new project with $ npm foundation new myApp.
$ npm foundation-app new myApp also does not work.

console writes this error:

$ foundation new myApp
module.js:329
throw err;
^

Error: Cannot find module 'config-chain'
at Function.Module._resolveFilename (module.js:327:15)
at Function.Module._load (module.js:278:25)
at Module.require (module.js:355:17)
at require (internal/module.js:13:17)
at Object. (/usr/local/lib/node_modules/foundation-cli/node_modules/npm/lib/config/core.js:2:10)
at Module._compile (module.js:399:26)
at Object.Module._extensions..js (module.js:406:10)
at Module.load (module.js:345:32)
at Function.Module._load (module.js:302:12)
at Module.require (module.js:355:17)

This dependencies installed in my system:

node -v v5.2.0; npm -v 3.3.12; git version 2.6.3; bower -v 1.7.1; gulp -v [05:21:23] CLI version 3.9.0; sass -v Sass 3.4.20 (Selective Steve) etc (other in screenshot below)

123

Tell me please what is wrong?

errorinstallation issue

Hello to everyone!
Can't install foundation-cli (don't know how to check this installed or not) or create new project with $ npm foundation new myApp.
$ npm foundation-app new myApp also does not work.

console writes this error:

$ foundation new myApp
module.js:329
throw err;
^

Error: Cannot find module 'config-chain'
at Function.Module._resolveFilename (module.js:327:15)
at Function.Module._load (module.js:278:25)
at Module.require (module.js:355:17)
at require (internal/module.js:13:17)
at Object. (/usr/local/lib/node_modules/foundation-cli/node_modules/npm/lib/config/core.js:2:10)
at Module._compile (module.js:399:26)
at Object.Module._extensions..js (module.js:406:10)
at Module.load (module.js:345:32)
at Function.Module._load (module.js:302:12)
at Module.require (module.js:355:17)

This dependencies installed in my system:

node -v v5.2.0; npm -v 3.3.12; git version 2.6.3; bower -v 1.7.1; gulp -v [05:21:23] CLI version 3.9.0; sass -v Sass 3.4.20 (Selective Steve) etc (other in screenshot below)

123

Tell me please what is wrong?

Brian Tan over 3 years ago

Refer http://foundation.zurb.com/sites/docs/installation.html

Remove old F5 foundation client?
Run command

$ foundation new