Menu icon Foundation
What is @import 'util/util';?

Hi
I'm just starting out here using F 6 with Codekit and Compass. I Just saved the _settings.scss file and codekit blasted out this:

   error /Users/max/Documents/Projects/UFD new website/urban fringe/scss/app.scss (Line 41 of /Users/max/Documents/Projects/UFD new website/urban fringe/scss/_settings.scss: File to import not found or unreadable: util/util.
Load paths:
  /Users/max/Documents/Projects/UFD new website/urban fringe/scss
  /Library/Ruby/Gems/2.0.0/gems/compass-core-1.0.3/stylesheets
  /Library/Ruby/Gems/2.0.0/gems/zurb-foundation-4.3.2/scss
  /Users/max/Documents/Projects/UFD new website/urban fringe/scss
  Compass::SpriteImporter
  Sass::Globbing::Importer)
Compilation failed in 1 files.
            

         

which has wrecked everything....
Line 41 is @import 'util/util';
I'm wondering what's going on here as it looks like Foundation hasn't loaded properly in Codekit (maybe?). Do I need to start all over again and install foundation differently? Anyone else having this problem?

codekitutil/utilsettings

Hi
I'm just starting out here using F 6 with Codekit and Compass. I Just saved the _settings.scss file and codekit blasted out this:

   error /Users/max/Documents/Projects/UFD new website/urban fringe/scss/app.scss (Line 41 of /Users/max/Documents/Projects/UFD new website/urban fringe/scss/_settings.scss: File to import not found or unreadable: util/util.
Load paths:
  /Users/max/Documents/Projects/UFD new website/urban fringe/scss
  /Library/Ruby/Gems/2.0.0/gems/compass-core-1.0.3/stylesheets
  /Library/Ruby/Gems/2.0.0/gems/zurb-foundation-4.3.2/scss
  /Users/max/Documents/Projects/UFD new website/urban fringe/scss
  Compass::SpriteImporter
  Sass::Globbing::Importer)
Compilation failed in 1 files.
            

         

which has wrecked everything....
Line 41 is @import 'util/util';
I'm wondering what's going on here as it looks like Foundation hasn't loaded properly in Codekit (maybe?). Do I need to start all over again and install foundation differently? Anyone else having this problem?

Dave Brockmeier about 4 years ago

"All of Foundation's Sass utilities are in the folder scss/util, and broken up into multiple files by category. You can import every utility file at once using this line of code:

@import 'util/util';"

Read more here: http://foundation.zurb.com/sites/docs/sass-functions.html

The docs are excellent.

Rafi Benkual about 4 years ago

I see Compass errors. Foundation 6 is using Libsass. Not sure if that's the issue or not but might ask the Codekit people.

Max Drake about 4 years ago

Yes, thank you Rafi. I emailed codekit and compass doesn't work with Foundation 6, so started again with Libsass. problem solved.

Edie Johnny about 4 years ago

This error occurred because you need to have into your scss folder (check what folder is in your config.rb, assuming you're using Compass) the Foundation's SCSS files.

You can find those files under the "bower_components/foundation-sites" folder. Just copy all of them to your Compass SCSS folder and probably it'll work. You may need to copy the "motion-ui" too, if you got an error at line 5 of your app.scss.

You can find it into the "bower_components/motion-ui/src" folder, but you can't just copy and paste because it has one "_settings.scss" file and you can't substitute it, so it may cause conflict. To fix that, copy those motion-ui files to another folder and change the line 5 of your app.scss to point to that folder.

With those settings, Compass'll compile fine.
See on this screenshot my folder tree, my config.rb and my app.scss: http://puu.sh/lFkSK/3267153931.png

Jeremy Snider about 4 years ago

Rather than copy the files to your scss folder, try adding the following to your config.rb file:

add_import_path "bower_components/foundation-sites/scss"
add_import_path "bower_components/motion-ui"

This will tell Codekit to look in those folders when importing. And it will allow Codekit to keep updating those files as updates are released, I would assume.

Curran Bhatia about 3 years ago

I had a similar error. I ended up having to run 'bower install', and then after that the error disappeared.