Menu icon Foundation
Opening Sublime Text in Yeti Launch

I am having trouble opening Sublime Text when in Yeti Launch. When I click on the Editor link it gives me this error.
"Can't open sublime since it is not installed in your PATH"

yeti-launch sublime-text

I am having trouble opening Sublime Text when in Yeti Launch. When I click on the Editor link it gives me this error.
"Can't open sublime since it is not installed in your PATH"

This post has been closed. No new replies can be added.

Tim Hartwick almost 4 years ago

Hi Christian,
In this version of Yeti Launch, it's looking for an installation within your application folder. Is your Sublime installed there?

Christian Tysklind almost 4 years ago

Yes I have it installed in my applications folder and it is not working.

Erik M almost 4 years ago

Thanks for letting us know Christian! What version of Sublime Text are you using, and what is the name of .app file in the Application folder? I'll be happy to figure this out with you! Apologies for the inconvenience!!

Thanks,
Erik

Christian Tysklind almost 4 years ago

Thats alright Erik. Just eager to work with the new app.

I have Sublime Text 2 and 3 installed. I have been running 2 for awhile but installed Sublime Text 3 just to make sure Yeti required the newest version (that did not work).

App names "Sublime Text" and "Sublime Text 2"

Erik M almost 4 years ago

Thanks for the info Christian. I'd like you to try entering a command into the terminal for me.

open -a "/Applications/Sublime Text.app" /Some/Folder/On/Your/Computer/To/Open

This is the command being executed under the hood, so lets manually execute it, and see what the output / result is. Please post your results / output here afterwards. (Note that you will need to change the path from what I provided to valid folder on your computer). I'd like to get this working for you, and determine if we need to put a patch into Yeti Launch to solve your bug. The feedback is extremely helpful.

Thanks!
Erik

Christian Tysklind almost 4 years ago

Success!

$ cTysklind$ open -a "/Applications/Sublime Text.app" /Users/cTysklind/Documents/lessons/new-project
$ Finished open -a "/Applications/Sublime Text.app" /Users/cTysklind/Documents/lessons/new-project

Erik M almost 4 years ago

Alright Christian thanks!

So on the plus side, we know it should work!

On the downer side, its strange that Yeti Launch is having problems despite it working in the terminal manually.

i'd like to sleep on this and brainstorm some ideas on what could cause the command to not working within Yeti Launch. What I'll probably do is create a new version of yeti launch and send it over (once I come up with something to try). In the meantime, you'll just have to work around it. Apologies for that! We'll get it working though :).

Talk to you soon!
Erik

Eric Tirado almost 4 years ago

Same issue here. Terminal works, but yeti launch doesn'.

Eric Tirado almost 4 years ago

Same issue here. Terminal works, but yeti launch doesn'.

Erik M almost 4 years ago

Alright everyone. It appears as though you will run into this issue if you have a space in the path.

We have patched Yeti Launch, and the new version is in QA right now.

Stay tuned. We will let you know when this release goes out.

Erik M almost 4 years ago

Hello everyone,

The patch been released! You can download it at http://foundation.zurb.com/develop/yeti-launch.html.

The patch addresses:

  • Javascript error on startup
  • Scss error reporting
  • Glitch for users with a space in their path trying to open an editor

Big enhancement:

  • Hosted code integration

A few other minor enhancements:

  • Allow underscores in project names
  • Change editor button in settings sidebar

Thanks everyone for your patience,
Erik

Andrew Blosser almost 4 years ago

Using yeti launch 1.0.1 I am still getting the same issue, except I'm using ATOM editor.

open -a "/Applications/Atom.app" works fine from a terminal. Doesn't work at all from yeti launch.

I get the same error:
Can't open atom since it is not installed in your PATH.

Eric Tirado almost 4 years ago

I get a "Finish Opening in Editor" button showing up now that doesn't do anything. It looks like this: https://www.dropbox.com/s/vnzw25d5iuotz4i/Screenshot%202015-12-01%2009.44.15.png?dl=0

Erik M almost 4 years ago

Hey Eric!

It's possible you don't have any of the supported text editors installed, but either way this is a bug. It is supposed to let you know that to use the open in editor feature, you must download one of the following: sublime text 2, sublime text 3, atom, brackets, or webstorm.

What text editor do you use?

Sorry for any trouble this is causing you, but thanks for letting us know!!

Thanks,
Erik

Eric Tirado almost 4 years ago

For some reason Sublime doesn't show, but I downloaded atom and brackets and it works for both. It must be something with my sublime install. Thanks Erik.

Erik M almost 4 years ago

Hey Eric!

Sublime needs to be installed in the /Applications folder or it will not be detected. Also, the application must be called either: Sublime Text.app or Sublime Text 2.app . Is it possible your install is named different / not in the /Applications folder?

Thanks,
Erik

Erik M almost 4 years ago

Hey Andrew,

I will look into this issue and see if we can solve it on our end. It's good to know you can workaround it by opening with sudo. Apologies for the trouble though. We will look into a fix.

Thanks,
Erik

Erik M almost 4 years ago

That is great to hear Eric! Thanks for getting in touch with us. Come back if you ever have any more questions or suggestions and we'd be happy to help :).

Thanks,
Erik