Menu icon Foundation
Ruby requirement for Foundation Apps?

So i was just looking up Foundation for Apps and i noticed that Ruby is required next to NodeJS. But seeing what NodeJS can do nowadays and what modules are available, where does Ruby and its gems come in?
If it is for SASS, why aren't you guys using node-sass yet? Or is it used for something else?

I like my projects nice and clean and having Node seems more than enough. Plus it seems that the setup-process is now longer, which is annoying if you have to tell collegues about how to install it when they are not going to do any programming but rather testing or designing.

So is it possible to get rid of it any time soon? Or is it required for something drastic?

rubyrequirement

So i was just looking up Foundation for Apps and i noticed that Ruby is required next to NodeJS. But seeing what NodeJS can do nowadays and what modules are available, where does Ruby and its gems come in?
If it is for SASS, why aren't you guys using node-sass yet? Or is it used for something else?

I like my projects nice and clean and having Node seems more than enough. Plus it seems that the setup-process is now longer, which is annoying if you have to tell collegues about how to install it when they are not going to do any programming but rather testing or designing.

So is it possible to get rid of it any time soon? Or is it required for something drastic?

Rafi Benkual almost 4 years ago

The only thing using Ruby in Foundation for Apps is Ruby Sass. Otherwise it's not being used anywhere else for the CLI or otherwise.

Martinspire almost 4 years ago

So basically gulp-ruby-sass hasn't been replaced by gulp-sass yet? Why not? Cause it only takes to remove the "-ruby" from the package.json to use the node-sass variant. I thought they changed it a while back?

Rafi Benkual almost 4 years ago

At the time it was released, a year ago, Libsass was not in feature parity with Ruby Sass and we wanted to use the latest features like Sass maps and more. We're working on F4A 2.0 no so it will be fully on Libsass.

Martinspire almost 4 years ago

But didn't they do a big makeover for Apps because they launched Foundation 6? Seems like a simple pull request is all it needs?

Rafi Benkual almost 4 years ago

I think I understand the confusion. If you spin up a project using our CLI there is no ruby in it. It pull from the foundation-apps-template

https://github.com/zurb/foundation-apps-template/blob/master/package.json

Martinspire almost 4 years ago

So it isn't a requirement anymore for Foundation for Apps? Then the readme should be updated