Menu icon Foundation
What is the right place for Foundation's dependencies?

I have installed Foundation via the CLI as shown here http://foundation.zurb.com/docs/sass.html#cli which means that I have used the Foundation Compass template https://github.com/zurb/foundation-compass-template
The index.html file in the root directory says that my dependencies (Modernizr and jQuery) should be referenced like this:

<script src="bower_components/modernizr/modernizr.js"></script>
<script src="bower_components/jquery/dist/jquery.min.js"></script>

I think that Foundation depends on Modernizr and jQuery, so why are all of its dependencies (FastClick, jQuery, jQuery Placeholder, jQuery Cookie and Modernizr) listed alongside in bower_components and not in bower_components/foundation/bower_components?

The reason why I am posting this question is because I wasn't sure which bower.json file I had to use when I wanted to specify the version of Modernizr. The bower.json file in the root directory or the bower.json file in bower_components/foundation?

Foundationcompassmodernizrdependencies

I have installed Foundation via the CLI as shown here http://foundation.zurb.com/docs/sass.html#cli which means that I have used the Foundation Compass template https://github.com/zurb/foundation-compass-template
The index.html file in the root directory says that my dependencies (Modernizr and jQuery) should be referenced like this:

<script src="bower_components/modernizr/modernizr.js"></script>
<script src="bower_components/jquery/dist/jquery.min.js"></script>

I think that Foundation depends on Modernizr and jQuery, so why are all of its dependencies (FastClick, jQuery, jQuery Placeholder, jQuery Cookie and Modernizr) listed alongside in bower_components and not in bower_components/foundation/bower_components?

The reason why I am posting this question is because I wasn't sure which bower.json file I had to use when I wanted to specify the version of Modernizr. The bower.json file in the root directory or the bower.json file in bower_components/foundation?

Rafi Benkual almost 4 years ago

There was an update to Modernizr with some breaking changes. We just released a new version today that lock it to Modernizr 2.8.3. If you try now you should be good to go!