Menu icon Foundation
Form abide with Foundation: confused

Hi guys,

I'm making a site at the moment and am using the Abide API for form verification. At this moment, the form is for registering new users to my site (it's a school project and it will be some sort of webshop). Now I want to submit the form, so I could handle the registration itself with PHP, after the form is valid.

I've searched Google, but everywhere it's completely different and not entirely clear what I should do to submit all values to a different page (registeruser.php). I myself would prefer using the POST method rather than GET variables in the URL.

Normally, I would use s getting annoying.

The source of the form: http://pastebin.com/8t9t96w3
How the form looks like (to visualize the code a bit): http://prntscr.com/8k0jwu

I hope someone would be able to help me out of this. I need my button to send all the data to a registeruser.php page, so I can insert everything properly into a database etc. etc.

Thanks in advance.

Foundationabideform

Hi guys,

I'm making a site at the moment and am using the Abide API for form verification. At this moment, the form is for registering new users to my site (it's a school project and it will be some sort of webshop). Now I want to submit the form, so I could handle the registration itself with PHP, after the form is valid.

I've searched Google, but everywhere it's completely different and not entirely clear what I should do to submit all values to a different page (registeruser.php). I myself would prefer using the POST method rather than GET variables in the URL.

Normally, I would use s getting annoying.

The source of the form: http://pastebin.com/8t9t96w3
How the form looks like (to visualize the code a bit): http://prntscr.com/8k0jwu

I hope someone would be able to help me out of this. I need my button to send all the data to a registeruser.php page, so I can insert everything properly into a database etc. etc.

Thanks in advance.

balazs sziklai about 4 years ago

Hi there!

Your form tag doesn`t have action or method attributes defined.

T K about 4 years ago

Hello,

I previously had it like:

This unfortunately didn't work. When the form was invalid, it showed the errors as it should, but when the form is valid, it goes to the same page (index.php in my case).

balazs sziklai about 4 years ago

had it like what?

T K about 4 years ago

Hmmm, did the forum just remove the tag? Oh whatever. Here is it again: http://pastebin.com/1pHt9MUB

I had it like this. When submitted, if form was invalid, it shows the errors as it should. When valid, it just goes to index.php (where it was from) rather than registeruser.php.

balazs sziklai about 4 years ago

Ok. without actualy seeing this in action is really hard to debug. So some things to check:

  • Is the form works without abide?
  • Is the relative path to your php working?
  • Whats that novalidate attr for?