Menu icon Foundation
Compass watch error: access denied

For some reason every time I try to run compass watch I run into this:

>compass watch
>>>>change detected at 13:00:58 to: app.scss
create stylesheets/app.css
Errno::EACCESS on line ["897"] of C: Permission denied - >>compass is polling for changes. press ctrl-c to stop

I've tried reinstalling compass and sass, and I'm also running in administrator.

(by the way I'm running the cmd prompt in windows 8 if that helps)

Sassrubyinstallwatchcompass

For some reason every time I try to run compass watch I run into this:

>compass watch
>>>>change detected at 13:00:58 to: app.scss
create stylesheets/app.css
Errno::EACCESS on line ["897"] of C: Permission denied - >>compass is polling for changes. press ctrl-c to stop

I've tried reinstalling compass and sass, and I'm also running in administrator.

(by the way I'm running the cmd prompt in windows 8 if that helps)


Wing-Hou Chan gave the most helpful answer for this post
Wing-Hou Chan almost 5 years ago

Howdy everyone!

I did a Google search and apparently this problem is due to a bug in the newer version of Compass.

Here is a thread from StackOverflow detailing a solution: http://stackoverflow.com/questions/22597223/errnoeaccess-permission-denied-running-compass-watch

Oleksandr Golovatyi1 almost 5 years ago

I have the same issue. Please help!!!!

Wing-Hou Chan almost 5 years ago

Howdy everyone!

I did a Google search and apparently this problem is due to a bug in the newer version of Compass.

Here is a thread from StackOverflow detailing a solution: http://stackoverflow.com/questions/22597223/errnoeaccess-permission-denied-running-compass-watch

Katherine Elsken almost 5 years ago

After reading that post, this is what solved my problem, but this might not work for everyone.

gem uninstall compass

gem uninstall sass

gem install compass --version "0.12.2"

gem install sass --version "3.2.10"

gem uninstall sass (once at this step pick the newer version of sass to uninstall )