Menu icon Foundation
Off Canvas Very Slow On Mobile

The off-canvas nav seems to be very sluggish on iphones in particular. I tried the solution suggested here: http://foundation.zurb.com/forum/posts/1175-off-canvas-performance-improvement but it didn't seem to help very much.

I do have really large images on my site, but I don't think it should be this slow. http://wordpress.remindermedia.com/

Wondering if anyone has any other suggestions for improving the performance, or if I need to switch to a different off canvas solution.

Thanks

off-canvasmobilenav

The off-canvas nav seems to be very sluggish on iphones in particular. I tried the solution suggested here: http://foundation.zurb.com/forum/posts/1175-off-canvas-performance-improvement but it didn't seem to help very much.

I do have really large images on my site, but I don't think it should be this slow. http://wordpress.remindermedia.com/

Wondering if anyone has any other suggestions for improving the performance, or if I need to switch to a different off canvas solution.

Thanks

Karl Ward over 5 years ago

Interesting, I can confirm it is very sluggish. The animation itself is fine once it starts, but it seems to take time before the "open" triggers. In fact, this was very similar to my problem (I was the one who posted that link above), and it does in fact speed up response time of the open button for me at least. It still has a sluggish factor, but it is acceptable:
http://mjau-mjau.com

The delay is because the browser first needs to render the layer into a transform-layer (thus to speed up the animation). I found out that the delay is proportional to the amount of content (especially images) in the main content area. In your case, I would imagine it might be the starting slideshow ... I would suggest eliminating some content just for testing purposes, and trying to figure out what content is making it lag so badly.

Robin Cox over 5 years ago

I have this problem too and as Karl suggests it gets more lag if the main content has heavy content.

Alex Plaza over 5 years ago

Seems to be okay with me, what version of Foundation you're all using? (5.2.1 here).