Menu icon Foundation
F4 Navbar break on ipad (landscape)

Hello guys,

I'm using F4 and getting a weird behaviour on iPad Landscape modus. Without talking much.. here is the site:

http://el.rub.de/drupal_test/

Keep in mind that the menu breaks only on ipad and landscape modus! The submenues starts poping not correctly and the links stops working.

I tried to add is_hover: true to ipad only that didnt helped.. The orbit breaks and links too, even the submenus..

Any help would be great!!

Foundation45navigtionmobileipadLandscapef4F5css

Hello guys,

I'm using F4 and getting a weird behaviour on iPad Landscape modus. Without talking much.. here is the site:

http://el.rub.de/drupal_test/

Keep in mind that the menu breaks only on ipad and landscape modus! The submenues starts poping not correctly and the links stops working.

I tried to add is_hover: true to ipad only that didnt helped.. The orbit breaks and links too, even the submenus..

Any help would be great!!

Steve Trask over 5 years ago

Hi Saif,

Looks to me as the Jquery is not loading correctly as I know this happend to a site of mine the other day, alos I am not sure if you have before the close of the body tag:

<script>
      $(document).foundation();
</script>

I do notice the drupal in your url, I know drupal runs an old Jquery and you need the correct version for Foundation to work so not sure if there is a conflict. there are the errors on the console of:

404 not found: http://el.rub.de/drupal_test/sites/all/themes/rubel_zf/css/social_foundicons.css

event.returnValue is deprecated. Please use the standard event.preventDefault() instead.

I know Drupal is quite hard with foundation as it is quite an old framework now as we have tried.

Hope this helps get you on the right track.