Menu icon Foundation
Tooltip (5.2) not working

After update to 5.2 the tooltips applied to links, stopped working... Is anyone having this problem?

tooltip

After update to 5.2 the tooltips applied to links, stopped working... Is anyone having this problem?

This post has been closed. No new replies can be added.

Rafi Benkual over 5 years ago

The tooltips are working http://cdpn.io/IkFAJ
Looks like the tip position can be changed.

Can you post your code so we can see what is happening?

Ubiratan Cunha over 5 years ago

Hi Rafi, these is an exemple of the code I´m using:

<ul class="l-icons-list l-vertical-divider l-inline-list left clearfix">
   <li><a data-tooltip title="Compartilhar" class="share tip-top" href="#">Facebook</a></li>
   <li><a data-tooltip title="Tweetar" class="tweet tip-top" href="#">Twitter</a></li>
   <li><a data-tooltip title="+1" class="plusone tip-top" href="#">Googleplus</a></li>
</ul>

For some reason the problem only heapens when using anchor tags.

Rafi Benkual over 5 years ago

Looks like the tooltips need the span class to to have styles applied. Here is your code working http://cdpn.io/IkFAJ

Keith Pickett over 5 years ago

Rafi:
Is there any way we can view your source? Viewing source from your Codepen links doesn't yield anything useful.
-Keith

Ubiratan Cunha over 5 years ago

In previous versions of the plugin it wasn´t necessary the use of span tags...

Ubiratan Cunha over 5 years ago

The problem is that I need to use the tooltip on link tags because in image replacement the tooltip can´t be visible inside the link tag...

Matt Camp about 5 years ago

What are in your classes (share, tweet and plusone)? Does you need classes like that for it to work?

Aswin Ramakrishnan over 4 years ago

I have the tooltips implemented with other DOM elements too. I don't know if you guys have figured this out already. But you'll need Modernizr for the tooltips to work. Works like a charm after referencing it.