Menu icon Foundation
Libsass or Compass

Can Foundation 5 be installed with both libsass, grunt and compass because when I tried installing, grunt was unable to work. Can it work or it has to be either libsass or compass

libsasscompassGruntSass

Can Foundation 5 be installed with both libsass, grunt and compass because when I tried installing, grunt was unable to work. Can it work or it has to be either libsass or compass

James Van Waza about 4 years ago

Rafi,

My error was that File to import not found or unreadable compass/css3. I am able to do compass watch, but when I run grunt, I get the error.

My app.scss file

``'
@import "settings";
@import "foundation";
@import "compass/css3";

/** Proper way to include @fontface using SASS */
@include font-face(AvenirNextCondensed-Bold, fonts/AvenirNextCondensed-Bold);
@include font-face(Avenir-Book, fonts/Avenir-Book);

Rafi Benkual about 4 years ago

Has to one or the other if you use our CLI.

Post back your error so we can help you more. Usually these things are due to your permission setting on your computer.