Menu icon Foundation
_settings.scss not changing scss, only css

Hello. I'm using Foundation 5.0.2.

When I un-comment-out stuff in _settings.scss or change it it's as if I haven't done anything. Yet if I add some css in that file as a test it does appear in app.css.

I'm importing in the correct order I think, here is my app.scss:
@import "settings";
@import "../../bower_components/foundation/scss/foundation";

test {
color: red;
}

both the test red and my _settings.scss test appear in app.css

I'm changing the correct _settings.scss file, in the scss folder not the bower one.

Thank you for your help.

Ps. I'm not sure if there's a problem with 5.0.2 v of Foundation or how easy it is to update?

scssSasscsssettings

Hello. I'm using Foundation 5.0.2.

When I un-comment-out stuff in _settings.scss or change it it's as if I haven't done anything. Yet if I add some css in that file as a test it does appear in app.css.

I'm importing in the correct order I think, here is my app.scss:
@import "settings";
@import "../../bower_components/foundation/scss/foundation";

test {
color: red;
}

both the test red and my _settings.scss test appear in app.css

I'm changing the correct _settings.scss file, in the scss folder not the bower one.

Thank you for your help.

Ps. I'm not sure if there's a problem with 5.0.2 v of Foundation or how easy it is to update?

Rafi Benkual about 4 years ago

Not sure if foundation is being imported correctly

Should be

@import "settings";
@import "foundation";

Clara about 4 years ago

Hi, thanks. I tried adding that in and got

'file to import not found or unreadable: foundation'

:|

so I don't have that file?

It currently says this in the importing file:

@import "settings";
@import "../../bower_components/foundation/scss/foundation";

I'm not sure why my files would be different to other peoples, I don't think I've changed anything and everything apart from settings.scss edits seems to be fine. :(

Rafi Benkual about 4 years ago

Did you use our CLI to create the project?

Clara about 4 years ago

I think I did. It was a year or so ago now as I paused the project. :| It's the only time I've ever used Foundation so I don't know the ins and outs of setting up Foundation. It seems ok aside from this...

I've heard maybe there's an issue with my version of Foundation?

Rafi Benkual about 4 years ago

No issues like this with any version of Foundation. I'm pretty sure the path to Foundation is not mapped right.

If anything the path should be bower_components/foundation/scss

Clara about 4 years ago

I reinstalled everything and set up a new project and it's working now :)

my app.scss settings are still:

@import "settings";
@import "../../bower_components/foundation/scss/foundation";

test {
color: red;
}

so that's weird?

I just thought there was an issue because I read a thread for this problem which said my version had this issue. I don't know if that was what fixed it or what... At least it's working now. :)