Menu icon Foundation
installing foundation- error

Hi guys been trying to get foundation installed on my system again unfortunately im having issues. Im running OSX 10.7 because i have an older system and had to wipe after i installed yosemti mistakenly, before I had 10.8 and didn't seem to be having issues. It seems like I can get the ruby update to work, ive tried home brew and rvm, and now at least when i check ruby version it says 2.2 but looks like foundation is still trying to use 1.8.

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:777:in `report_activate_error': Could not find RubyGem foundation (>= 0) (Gem::LoadError)
    from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:211:in `activate'
	from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:1056:in `gem'
	from /usr/bin/foundation:18
            

         

ruby

Hi guys been trying to get foundation installed on my system again unfortunately im having issues. Im running OSX 10.7 because i have an older system and had to wipe after i installed yosemti mistakenly, before I had 10.8 and didn't seem to be having issues. It seems like I can get the ruby update to work, ive tried home brew and rvm, and now at least when i check ruby version it says 2.2 but looks like foundation is still trying to use 1.8.

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:777:in `report_activate_error': Could not find RubyGem foundation (>= 0) (Gem::LoadError)
    from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:211:in `activate'
	from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:1056:in `gem'
	from /usr/bin/foundation:18
            

         
Rafi Benkual over 4 years ago

Foundation 5.2.2 is using works on any Ruby version 1.9+ (well the CLI actually)

Did you run 'gem install foundation'?