Menu icon Foundation
Installation Error?

Hello,

I have this issue with the initial installation of Foundation via the sass route. I've followed the tutorials to the letter, but I keep getting an error message stating :-

"Installing dependencies with bower...
run compass compile from "./1"
Could not find proper version of compass (1.0.1) in any of the sources
Run `bundle install` to install missing gems."

I also check the gems folder in the library as well and there are no gems to be found even though when I do a version check for the gems via the terminal it says they are installed with the correct versions.

Any help will be much appriated.

installation; gems; error; compass; compass error;

Hello,

I have this issue with the initial installation of Foundation via the sass route. I've followed the tutorials to the letter, but I keep getting an error message stating :-

"Installing dependencies with bower...
run compass compile from "./1"
Could not find proper version of compass (1.0.1) in any of the sources
Run `bundle install` to install missing gems."

I also check the gems folder in the library as well and there are no gems to be found even though when I do a version check for the gems via the terminal it says they are installed with the correct versions.

Any help will be much appriated.

This post has been closed. No new replies can be added.

Rafi Benkual about 4 years ago

What happened when you ran gem install foundation?

Any errors?

I also suggest going the Libsass route as it has less dependancies and its faster.

You can also use http://mixture.io/ as its free.

Bruno about 4 years ago

Hello,

I had the same problem.
I resolve it with install specific version of gem package with this type of command line :
gem install package_name -v 'X.X.XX'

gem install compass -v 1.0.1
gem install chunky_png -v '1.3.3'
gem install multi_json -v '1.10.1'
gem install sass -v '3.4.9'
gem install compass-core -v '1.0.1'
gem install ffi -v '1.9.6'

After do that, project generation done well ;-)

bundle install command give me this result :
Using chunky_png 1.3.3
Using multi_json 1.10.1
Using sass 3.4.9
Using compass-core 1.0.1
Using compass-import-once 1.0.5
Using rb-fsevent 0.9.4
Using ffi 1.9.6
Using rb-inotify 0.9.5
Using compass 1.0.1
Using bundler 1.8.4

May be some packages was install before...

I hope that helps,

Kind regards,

Bruno