Menu icon Foundation
Foundation CLI freezes at "installing dependencies with bower"

Anyone else encountered this problem?

Foundation 5foundation clibower

Anyone else encountered this problem?

Daniel Nyman over 4 years ago

I can also confirm this.

Windows 8.1 Enterprise x64, been at it for 2 days now. Very frustrating not getting it to work :(

Max Audron over 4 years ago

Exactly the same issue and i have a 100k internet.
Also from were it gets the bower components? Because i aslo had problem geting the gems from ruby i needed to use --source

Kris Livingstone over 4 years ago

Managed to get it working by reverting node and ruby to the versions that were installed on my old computer (not sure which helped).

rubyinstaller-1.9.3-p484.exe
node-v0.10.22-x64.msi

Tonybyte over 4 years ago

Same here. There is a dupe post: http://foundation.zurb.com/forum/posts/22947-foundation-5-sass-problem-with-creating-a-new-project

Meanwhile, you can cancel out when its stuck and run "update bower" for the install to finish (seems to work for me until I can find a solution).

I have:
ruby 1.9.3p551
node v0.12.0

Rafi Benkual over 4 years ago

Wasn't able to replicate it. You need a good internet connection and Bower doesn't like sudo commands.

Colin Smith over 4 years ago

I have same problem. Windows 7 x64
C:\xampp>gem list

*** LOCAL GEMS ***

bigdecimal (1.1.0)
bower (0.0.2)
bundler (1.8.2)
chunky_png (1.3.4)
compass (1.0.3)
compass-core (1.0.3)
compass-import-once (1.0.5)
ffi (1.9.6 x86-mingw32)
foundation (1.0.4)
io-console (0.3)
json (1.5.5)
minitest (2.5.1)
multi_json (1.10.1)
rake (0.9.2.2)
rb-fsevent (0.9.4)
rb-inotify (0.9.5)
rdoc (3.9.5)
sass (3.4.12)
thor (0.19.1)

C:\xampp>foundation new test1
Creating ./test1
create test1
Cloning into 'test1'...
remote: Counting objects: 120, done.
rRemote: Total 120 (delta 0), reused 0 (delta 0), pack-reused 120eceiving object
Receiving objects: 100% (120/120), 40.77 KiB | 0 bytes/s, done.
Resolving deltas: 100% (48/48), done.

Checking connectivity... done.
Installing dependencies with bower...

This is as far as it gets. I have 35Mb/s internet connection

Thanks for your help

Regards
Colin

Zachary Lyons over 4 years ago

Here is a dump of what I see when I CTRL+C out of the hung thread. Note that I am using a non-default install location for Ruby (G:/Programs/Ruby/Ruby193)

G:\Desktop>foundation new proj2
Creating ./proj2
create proj2
Cloning into 'proj2'...
remote: Counting objects: 120, done.
remote: Total 120 (delta 0), reused 0 (delta 0), pack-reused 120
Receiving objects: 100% (120/120), 40.77 KiB | 0 bytes/s, done.
Resolving deltas: 100% (48/48), done.
Checking connectivity... done.
Installing dependencies with bower...
CG:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/thor-0.19.1/lib/thor/actions.rb:254:in `': Interrupt
from G:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/thor-0.19.1/lib/thor/actions.rb:254:in
run'
from G:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/foundation-1.0.4/lib/foundation/cli/generator.rb:130:in block in new'
from G:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/thor-0.19.1/lib/thor/actions.rb:184:in
block in inside'
from G:/Programs/Ruby/Ruby193/lib/ruby/1.9.1/fileutils.rb:125:in chdir'
from G:/Programs/Ruby/Ruby193/lib/ruby/1.9.1/fileutils.rb:125:in
cd'
from G:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/thor-0.19.1/lib/thor/actions.rb:184:in inside'
from G:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/foundation-1.0.4/lib/foundation/cli/generator.rb:128:in
new'
from G:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/thor-0.19.1/lib/thor/command.rb:27:in run'
from G:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/thor-0.19.1/lib/thor/invocation.rb:126:in
invoke_command'
from G:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/thor-0.19.1/lib/thor.rb:359:in dispatch'
from G:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/thor-0.19.1/lib/thor/base.rb:440:in
start'
from G:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/foundation-1.0.4/bin/foundation:4:in <top (required)>'
from G:/Programs/Ruby/Ruby193/bin/foundation:23:in
load'
from G:/Programs/Ruby/Ruby193/bin/foundation:23:in `'
Terminate batch job (Y/N)?

Zachary Lyons over 4 years ago

Here is a dump of what I see when I CTRL+C out of the hung thread. Note that I am using a non-default install location for Ruby (G:/Programs/Ruby/Ruby193)

G:\Desktop>foundation new proj2
Creating ./proj2
create proj2
Cloning into 'proj2'...
remote: Counting objects: 120, done.
remote: Total 120 (delta 0), reused 0 (delta 0), pack-reused 120
Receiving objects: 100% (120/120), 40.77 KiB | 0 bytes/s, done.
Resolving deltas: 100% (48/48), done.
Checking connectivity... done.
Installing dependencies with bower...
CG:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/thor-0.19.1/lib/thor/actions.rb:254:in `': Interrupt
from G:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/thor-0.19.1/lib/thor/actions.rb:254:in
run'
from G:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/foundation-1.0.4/lib/foundation/cli/generator.rb:130:in block in new'
from G:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/thor-0.19.1/lib/thor/actions.rb:184:in
block in inside'
from G:/Programs/Ruby/Ruby193/lib/ruby/1.9.1/fileutils.rb:125:in chdir'
from G:/Programs/Ruby/Ruby193/lib/ruby/1.9.1/fileutils.rb:125:in
cd'
from G:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/thor-0.19.1/lib/thor/actions.rb:184:in inside'
from G:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/foundation-1.0.4/lib/foundation/cli/generator.rb:128:in
new'
from G:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/thor-0.19.1/lib/thor/command.rb:27:in run'
from G:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/thor-0.19.1/lib/thor/invocation.rb:126:in
invoke_command'
from G:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/thor-0.19.1/lib/thor.rb:359:in dispatch'
from G:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/thor-0.19.1/lib/thor/base.rb:440:in
start'
from G:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/foundation-1.0.4/bin/foundation:4:in <top (required)>'
from G:/Programs/Ruby/Ruby193/bin/foundation:23:in
load'
from G:/Programs/Ruby/Ruby193/bin/foundation:23:in `'
Terminate batch job (Y/N)?

Zachary Lyons over 4 years ago

Here is a dump of what I see when I CTRL+C out of the hung thread. Note that I am using a non-default install location for Ruby (G:/Programs/Ruby/Ruby193)

G:\Desktop>foundation new proj2
Creating ./proj2
create proj2
Cloning into 'proj2'...
remote: Counting objects: 120, done.
remote: Total 120 (delta 0), reused 0 (delta 0), pack-reused 120
Receiving objects: 100% (120/120), 40.77 KiB | 0 bytes/s, done.
Resolving deltas: 100% (48/48), done.
Checking connectivity... done.
Installing dependencies with bower...
CG:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/thor-0.19.1/lib/thor/actions.rb:254:in `': Interrupt
from G:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/thor-0.19.1/lib/thor/actions.rb:254:in
run'
from G:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/foundation-1.0.4/lib/foundation/cli/generator.rb:130:in block in new'
from G:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/thor-0.19.1/lib/thor/actions.rb:184:in
block in inside'
from G:/Programs/Ruby/Ruby193/lib/ruby/1.9.1/fileutils.rb:125:in chdir'
from G:/Programs/Ruby/Ruby193/lib/ruby/1.9.1/fileutils.rb:125:in
cd'
from G:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/thor-0.19.1/lib/thor/actions.rb:184:in inside'
from G:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/foundation-1.0.4/lib/foundation/cli/generator.rb:128:in
new'
from G:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/thor-0.19.1/lib/thor/command.rb:27:in run'
from G:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/thor-0.19.1/lib/thor/invocation.rb:126:in
invoke_command'
from G:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/thor-0.19.1/lib/thor.rb:359:in dispatch'
from G:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/thor-0.19.1/lib/thor/base.rb:440:in
start'
from G:/Programs/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/foundation-1.0.4/bin/foundation:4:in <top (required)>'
from G:/Programs/Ruby/Ruby193/bin/foundation:23:in
load'
from G:/Programs/Ruby/Ruby193/bin/foundation:23:in `'
Terminate batch job (Y/N)?

Zachary Lyons over 4 years ago

I was able to resolve this by following arkkab's instructions on StackOverflow.

http://stackoverflow.com/a/28514698/610832

TL;DR: downgrade to NodeJS 0.10.36 at http://nodejs.org/dist/

Zachary Lyons over 4 years ago

I was able to resolve this by following arkkab's instructions on StackOverflow.

http://stackoverflow.com/a/28514698/610832

TL;DR: downgrade to NodeJS 0.10.36 at http://nodejs.org/dist/

Zachary Lyons over 4 years ago

I was able to resolve this by following arkkab's instructions on StackOverflow.

http://stackoverflow.com/a/28514698/610832

TL;DR: downgrade to NodeJS 0.10.36 at http://nodejs.org/dist/

Kris Livingstone over 4 years ago

Same problem. Win 7 x64, very fast connection.

Installing dependencies with bower...

Tried an earlier bower version too... no luck.