Menu icon Foundation
Foundation 5 and SASS Install

I managed to get everything installed on the last computer, with help from this forum.

But the computer failed, and I am trying to install on a different computer, Windows 7 64 bit, 4Mb memory, Wampserver

And this time, I am having problems with bower...

I can reach https://bower.herokuapp.com/packages/jquery-placeholder with a browser.

Can anyone make any suggestions, please?

C:\Users\Pete>foundation new f2
DL is deprecated, please use Fiddle
Creating ./f2
create f2
Cloning into 'f2'...
remote: Counting objects: 117, done.
remote: Total 117 (delta 0), reused 0 (delta 0)
Receiving objects: 100% (117/117), 40.07 KiB | 0 bytes/s, done.
Resolving deltas: 100% (46/46), done.
Checking connectivity... done.
Installing dependencies with bower...
bower retry Request to https://bower.herokuapp.com/packages/jquery-placeholder failed with ETIMEDOUT, retrying in 1.2s
bower retry Request to https://bower.herokuapp.com/packages/jquery-placeholder failed with ETIMEDOUT, retrying in 2.1s
bower retry Request to https://bower.herokuapp.com/packages/jquery-placeholder failed with ETIMEDOUT, retrying in 4.1s
bower retry Request to https://bower.herokuapp.com/packages/jquery-placeholder failed with ETIMEDOUT, retrying in 15.4s
bower retry Request to https://bower.herokuapp.com/packages/jquery-placeholder failed with ETIMEDOUT, retrying in 22.5s
bower jquery-placeholder#~2.0.7 ETIMEDOUT Request to https://bower.herokuapp.com/packages/jquery-placeholder failed: ETIMEDOUT
C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/foundation-1.0.4/lib/foundation/cli/generator.rb:131:in `read': No such file or directory @ rb_sysopen - C:/Users/Pete/f2/bower_components/foundation/scss/foundation/_settings.scss (Errno::ENOENT)
from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/foundation-1.0.4/lib/foundation/cli/generator.rb:131:in `block (2 levels) in new'
from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/foundation-1.0.4/lib/foundation/cli/generator.rb:131:in `open'
from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/foundation-1.0.4/lib/foundation/cli/generator.rb:131:in `block in new'
from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor/actions.rb:184:in `block in inside'
from C:/Ruby21-x64/lib/ruby/2.1.0/fileutils.rb:125:in `chdir'
from C:/Ruby21-x64/lib/ruby/2.1.0/fileutils.rb:125:in `cd'
from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor/actions.rb:184:in `inside'
from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/foundation-1.0.4/lib/foundation/cli/generator.rb:128:in `new'
from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor/command.rb:27:in `run'
from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor/invocation.rb:126:in `invoke_command'
from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor.rb:359:in `dispatch'
from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor/base.rb:440:in `start'
from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/foundation-1.0.4/bin/foundation:4:in `'
from C:/Ruby21-x64/bin/foundation:23:in `load'
from C:/Ruby21-x64/bin/foundation:23:in `'

Sassinstallbower

I managed to get everything installed on the last computer, with help from this forum.

But the computer failed, and I am trying to install on a different computer, Windows 7 64 bit, 4Mb memory, Wampserver

And this time, I am having problems with bower...

I can reach https://bower.herokuapp.com/packages/jquery-placeholder with a browser.

Can anyone make any suggestions, please?

C:\Users\Pete>foundation new f2
DL is deprecated, please use Fiddle
Creating ./f2
create f2
Cloning into 'f2'...
remote: Counting objects: 117, done.
remote: Total 117 (delta 0), reused 0 (delta 0)
Receiving objects: 100% (117/117), 40.07 KiB | 0 bytes/s, done.
Resolving deltas: 100% (46/46), done.
Checking connectivity... done.
Installing dependencies with bower...
bower retry Request to https://bower.herokuapp.com/packages/jquery-placeholder failed with ETIMEDOUT, retrying in 1.2s
bower retry Request to https://bower.herokuapp.com/packages/jquery-placeholder failed with ETIMEDOUT, retrying in 2.1s
bower retry Request to https://bower.herokuapp.com/packages/jquery-placeholder failed with ETIMEDOUT, retrying in 4.1s
bower retry Request to https://bower.herokuapp.com/packages/jquery-placeholder failed with ETIMEDOUT, retrying in 15.4s
bower retry Request to https://bower.herokuapp.com/packages/jquery-placeholder failed with ETIMEDOUT, retrying in 22.5s
bower jquery-placeholder#~2.0.7 ETIMEDOUT Request to https://bower.herokuapp.com/packages/jquery-placeholder failed: ETIMEDOUT
C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/foundation-1.0.4/lib/foundation/cli/generator.rb:131:in `read': No such file or directory @ rb_sysopen - C:/Users/Pete/f2/bower_components/foundation/scss/foundation/_settings.scss (Errno::ENOENT)
from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/foundation-1.0.4/lib/foundation/cli/generator.rb:131:in `block (2 levels) in new'
from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/foundation-1.0.4/lib/foundation/cli/generator.rb:131:in `open'
from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/foundation-1.0.4/lib/foundation/cli/generator.rb:131:in `block in new'
from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor/actions.rb:184:in `block in inside'
from C:/Ruby21-x64/lib/ruby/2.1.0/fileutils.rb:125:in `chdir'
from C:/Ruby21-x64/lib/ruby/2.1.0/fileutils.rb:125:in `cd'
from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor/actions.rb:184:in `inside'
from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/foundation-1.0.4/lib/foundation/cli/generator.rb:128:in `new'
from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor/command.rb:27:in `run'
from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor/invocation.rb:126:in `invoke_command'
from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor.rb:359:in `dispatch'
from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor/base.rb:440:in `start'
from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/foundation-1.0.4/bin/foundation:4:in `'
from C:/Ruby21-x64/bin/foundation:23:in `load'
from C:/Ruby21-x64/bin/foundation:23:in `'

Rian Jacobs over 4 years ago

I have the same problem, Any solution to it yet?

Pete Clark over 4 years ago

Nothing as yet... fingers still crossed.

Elizabeth Ojeda over 4 years ago

I have the same problem.
For the time being, I found this template: https://github.com/zurb/foundation-compass-template
By accessing it through Command Prompt, and running:
bower install
It gets the latest Foundation release into the project, and I believe you will have all needed files to work on, while this problem is solved.

Pete Clark over 4 years ago

Thanks, Elizabeth,

This method of manual installation seems to work so far, so at least I continue with the outstanding projects.

But it would be really useful if I could find out what was causing the problem, and get back to everything working properly

Daniel Vos over 4 years ago

I'm having the same problem with bower on Windows 7.

However, this does look helpful in the meantime: https://github.com/zurb/foundation-compass-template

Noel Dixon over 4 years ago

This is happening to me right now. I successfully compiled two (2) days ago under Windows 8, but after a refresh on the same machine to Windoze 8.1, I now have the exact ETIMEDOUT as Pete.

Any news on this, keen to get back to the way I was doing things?!

Noel Dixon over 4 years ago

Pete,

I found if you just Ctrl+c out of it early, you can go to the project directory (command line) and while in there type:

 > foundation update

This seems to refresh the instance and add the rest of the missing bower_components, etc. This works for both the compass and libsass processes.

Hope it helps.

Antonio Caparrelli over 4 years ago

Thank you Noel, it worked for me ;)