Menu icon Foundation
First installation step fails on Windows

The first step of the install instructions on http://foundation.zurb.com/apps/docs/#!/ ...

npm install -g foundation-cli bower gulp
            

         

... fails for me with the error message "npm ERR! uid must be an unsigned int". I have filed a github issue https://github.com/npm/npm/issues/6995 and am guessing that the dash in the first package name causes the failure.

This works fine though:

npm install -g foundation-cli
npm install -g bower gulp
            

         

installwindows

The first step of the install instructions on http://foundation.zurb.com/apps/docs/#!/ ...

npm install -g foundation-cli bower gulp
            

         

... fails for me with the error message "npm ERR! uid must be an unsigned int". I have filed a github issue https://github.com/npm/npm/issues/6995 and am guessing that the dash in the first package name causes the failure.

This works fine though:

npm install -g foundation-cli
npm install -g bower gulp
            

         
Antonin Januska almost 5 years ago

One thing I can suggest is running the command as an administrator. I tried to recreate your issue (remove those packages and install them again) and didn't have a problem.

The other thing could be your NPM and Node versions. There have been some upgrades and it looks like this issue has popped up often.

You can check your npm version with npm -v. I'm currently on 1.4.28. You can check your node version via node -v. I'm currently on 0.10.33.

Karl Johan Kleist almost 5 years ago

Thanks for your assistance, Antonin.

The npm maintainers seem to have found the underlying problem (a race condition related to the cache): https://github.com/npm/npm/pull/7107

And as already said: installing the packages separately solved the problem.

jason roy over 1 year ago

Is there any another method to get the free dvd player download windows 10 for running all the qualities of videos the windows operating system.

thungoc over 1 year ago

Already got this problem and now fixed , just download kali amd64 don't download the 32bits and run it with Gui Installation don't use classic and about network step take it empty
and after you will got Installation Finished !