Menu icon Foundation
"Error: Gemfile version of Sass not found" - Not really an error?

Hi all, Foundation newbie here using 64 bit Windows 7.

Following the instructions on "http://foundation.zurb.com/apps/getting-started.html" I installed Foundation for Apps, and everything seems fine, i.e. localhost:8080 serves the page "Foundation Angular" with a five bullet list.

However:

When I entered the command "foundation-apps watch" I got this:

{ [Error: Gemfile version of Sass not found. Install missing gems with `bundle install`.]
  message: 'Gemfile version of Sass not found. Install missing gems with `bundle install`.',
  showStack: false,
  showProperties: true,
  plugin: 'gulp-ruby-sass',
  __safety: { toString: [Function] } }
[10:54:32] Finished 'sass' after 2.05 s

But is this really an "Error"? Seems more like "Info" (or possibly "Warning") to me since seemingly everything went fine.

Should I be worried? It is tempting trying to "gem install sass" as (probably incorrectly) suggested by "https://github.com/zurb/foundation-apps-template"...

installwindows

Hi all, Foundation newbie here using 64 bit Windows 7.

Following the instructions on "http://foundation.zurb.com/apps/getting-started.html" I installed Foundation for Apps, and everything seems fine, i.e. localhost:8080 serves the page "Foundation Angular" with a five bullet list.

However:

When I entered the command "foundation-apps watch" I got this:

{ [Error: Gemfile version of Sass not found. Install missing gems with `bundle install`.]
  message: 'Gemfile version of Sass not found. Install missing gems with `bundle install`.',
  showStack: false,
  showProperties: true,
  plugin: 'gulp-ruby-sass',
  __safety: { toString: [Function] } }
[10:54:32] Finished 'sass' after 2.05 s

But is this really an "Error"? Seems more like "Info" (or possibly "Warning") to me since seemingly everything went fine.

Should I be worried? It is tempting trying to "gem install sass" as (probably incorrectly) suggested by "https://github.com/zurb/foundation-apps-template"...

This post has been closed. No new replies can be added.

Rafi Benkual almost 5 years ago

Them gemfile is requiring Sass 3.4+, what version are you on?

Karl Johan Kleist almost 5 years ago

Thanks, Rafi, for trying to assist.

I haven't yet investigated the inner guts of Foundation for Apps, just followed "http://foundation.zurb.com/apps/getting-started.html" which doesn't mention Sass at all.

Do I need a Sass gem, or does Foundation for Apps use Node Sass (Libsass)?

Karl Johan Kleist almost 5 years ago

Closing this after having gotten answers from gulpfile.js and https://github.com/zurb/foundation-apps/issues/209