Menu icon Foundation
Abide predefined validation not working

I've just started working with foundation and am trying to use abide for form validation. No matter what i do i can't get it to work! I've dumbed it down to make it as simple as possible and am still getting odd behavior.

When i specify the input type as alpha then the box doesn't pickup foundations styles and it does not validate the contents. I've tried this with several types of validation. The only one that works is email.

I've looked in my foundation.js file just out of curiosity and all of the abide stuff is defined there. I've got no clue whats going on. Any advice is greatly appreciated!

I'm on foundation 5 and using the built in abide v5.3.1

Thanks,

            
//This does not work
<form name="testform" data-abide>
    <input type="alpha" required>
    <input type="submit" class="button">
</form>


//this does work
<form name="testform" data-abide>
    <input type="email" required>
    <input type="submit" class="button">
</form>

abidevalidationabide validationnot workingpredefined

I've just started working with foundation and am trying to use abide for form validation. No matter what i do i can't get it to work! I've dumbed it down to make it as simple as possible and am still getting odd behavior.

When i specify the input type as alpha then the box doesn't pickup foundations styles and it does not validate the contents. I've tried this with several types of validation. The only one that works is email.

I've looked in my foundation.js file just out of curiosity and all of the abide stuff is defined there. I've got no clue whats going on. Any advice is greatly appreciated!

I'm on foundation 5 and using the built in abide v5.3.1

Thanks,

            
//This does not work
<form name="testform" data-abide>
    <input type="alpha" required>
    <input type="submit" class="button">
</form>


//this does work
<form name="testform" data-abide>
    <input type="email" required>
    <input type="submit" class="button">
</form>