Menu icon Foundation
Libsass functions:13: error

Hi all,

I'm using libsass and getting the following error when I make a change to the scss file ...

Warning: bower_components/foundation/scss/foundation/functions:13: error: error reading values after $modules

I've seen other posts on this but as none have been updated for 3 months I would have guessed the issue would have been resolved by now.

The only thing that has changed on my system is that I've installed Foundation For Apps. I'm not using that for the site having the issue above but has the installation maybe give me an incompatible file somewhere?

Any ideas on a fix would be appreciated greatly.

Thanks.

compilescsslibsass

Hi all,

I'm using libsass and getting the following error when I make a change to the scss file ...

Warning: bower_components/foundation/scss/foundation/functions:13: error: error reading values after $modules

I've seen other posts on this but as none have been updated for 3 months I would have guessed the issue would have been resolved by now.

The only thing that has changed on my system is that I've installed Foundation For Apps. I'm not using that for the site having the issue above but has the installation maybe give me an incompatible file somewhere?

Any ideas on a fix would be appreciated greatly.

Thanks.

Rafi Benkual almost 5 years ago

If you update your GemFile to Sass 3.4 that should do it. We were finally able to move to 3.4 since Libsass is catching up!

John Marshall almost 5 years ago

This doesn't work I'm afraid. I'm on Sass 3.4.9 (Selective Steve) and Grunt still falls over at the exact same point. Thanks for your help but please can you suggest something else?

George S almost 5 years ago

Yep. I'm having the same issue. Exact same error.

Per the advice, I just updated to sass 3.4.9 (Previously 3.2.19) and I'm still getting the same error.

George S almost 5 years ago

Answer: Found here http://stackoverflow.com/a/25778642/1827642

I'm not sure what this will break but basically removing a couple instances of !global in _functions.scss did the trick.

If this is bad, I'm all for suggestions about other options...

If it helps at all:
Foundation 5.5.0 w sass 3.4.9

George S almost 5 years ago

Ok, looks like the solution is here: https://github.com/zurb/foundation/issues/6106

I updated my sass gem but I didn' update package.json

Per gakimball
Go into your package.json and check what version of node-sass and grunt-sass you're using. Ideally it should be:
{
"node-sass" : "~1.2.3",
"grunt-sass": "~0.17.0"
}

Mine was out of date.

John Marshall almost 5 years ago

Thanks George. My versions are indeed out of date but (forgive me) I have no idea how to update them. Please could someone advice step by step on how I get sorted? Thanks.

John Marshall almost 5 years ago

Anyone please? I'm stuck without this info. I've tried every update I know but the versions shown in my package.json file don't change.

Bob den Otter almost 5 years ago

Hi John,

There's several options to fix this:

  • Edit package.json by hand, and tweak the version numbers how you want them to be, then run npm install. This is slightly hackish.

  • Alternatively, run npm update --save-dev.

If those don't work, do the following:

  • Edit package.json, and remove the two lines with node-sass and grunt-sass. Make sure that it stays valid JSON: No trailing comma after the last 'require'.

  • Run these commands:

    npm install grunt-sass --save-dev
    npm install node-sass --save-dev

And you should be good to go.