Menu icon Foundation
App install issues; No response on 8080 using npm start

Hello all,

I wanted to try out the new foundation-apps release and see how I can use it for the client portion within an existing express app. I started by following the CLI instructions and ran into a few issues:

Russs-MBP:WebstormProjects russwatson$ foundation-apps new testFA

/|
| | /| .
. /\| \/ |/|
|\/ |
||\__/\____/|| Thanks for using Foundation for Apps!
___|| ======== ||___ -------------------------------------
/___|| O O ||___\ Let's set up a new project.
|| ______, || It shouldn't take more than a minute.
/| |\
/_/\\/\ /\//\_\
\/\\//\/
\/

Downloading the Foundation for Apps template...
Done downloading!

Installing dependencies...
npm => bower => bundler

You're all set! Now run foundation-apps watch while inside the testFA folder.

Russs-MBP:WebstormProjects russwatson$ cd testFA/
Russs-MBP:testFA russwatson$ foundation-apps watch

> foundation-apps-template@0.0.1 start /Users/russwatson/WebstormProjects/testFA
> gulp

Error: Cannot find module 'gulp-front-matter'
at Function.Module._resolveFilename (module.js:338:15)
at Function.Module._load (module.js:280:25)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object. (/Users/russwatson/WebstormProjects/testFA/gulpfile.js:4:22)
at Module._compile (module.js:456:26)
at Object.Module._extensions..js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)

npm ERR! foundation-apps-template@0.0.1 start: `gulp`
npm ERR! Exit status 8
npm ERR!
npm ERR! Failed at the foundation-apps-template@0.0.1 start script.
npm ERR! This is most likely a problem with the foundation-apps-template package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! gulp
npm ERR! You can get their info via:
npm ERR! npm owner ls foundation-apps-template
npm ERR! There is likely additional logging output above.
npm ERR! System Darwin 14.0.0
npm ERR! command "node" "/usr/local/bin/npm" "start"
npm ERR! cwd /Users/russwatson/WebstormProjects/testFA
npm ERR! node -v v0.10.31
npm ERR! npm -v 1.4.23
npm ERR! code ELIFECYCLE
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /Users/russwatson/WebstormProjects/testFA/npm-debug.log
npm ERR! not ok code 0

Screen shot 2014 12 05 at 1.26.55 pm

No problem, I did 'npm install gulp-front-matter'. I subsequently received errors for the following packages:

"gulp-ruby-sass"
"gulp-concat"
"gulp-connect"

Now I'm running into an issue where the server that is started at 8080 returns no response and I'm scratching my head trying to figure out what's going on:

[12:13:28] Using gulpfile ~/WebstormProjects/testFA/gulpfile.js
[12:13:28] Starting 'build'...
[12:13:28] Starting 'clean'...
[12:13:28] Starting 'server:start'...
[12:13:28] Finished 'server:start' after 18 ms
[12:13:28] Finished 'build' after 20 ms
[12:13:28] Starting 'default'...
[12:13:28] Finished 'default' after 13 ms
[12:13:28] Server started http://localhost:8080
[12:13:28] Finished 'clean' after 38 ms
[12:13:28] Starting 'copy'...
[12:13:28] Starting 'clean-partials'...
[12:13:28] Starting 'sass'...
[12:13:28] Starting 'uglify-angular'...
[12:13:28] Finished 'clean-partials' after 13 ms
[12:13:28] Starting 'copy-partials'...
[12:13:28] Finished 'copy-partials' after 5.6 ms
[12:13:30] Finished 'copy' after 1.8 s
[12:13:30] Finished 'uglify-angular' after 2.24 s
[12:13:30] Starting 'uglify'...
[12:13:30] gulp-ruby-sass: directory
[12:13:31] Finished 'uglify' after 499 ms
[12:13:33] gulp-ruby-sass: write app.css
write app.css.map
[12:13:34] Finished 'sass' after 5.76 s
[12:13:34] Starting 'copy'...
[12:13:34] Finished 'copy' after 5.25 ms
[12:13:34] Starting 'copy-templates'...
[12:13:34] Finished 'copy-templates' after 8.92 ms
Successfully built.

Screen shot 2014 12 05 at 1.31.43 pm

I'm continuing to try and sleuth this out, but has anyone already jumped this hurdle?

zurb-foundation-appsappsfoundation for apps

Hello all,

I wanted to try out the new foundation-apps release and see how I can use it for the client portion within an existing express app. I started by following the CLI instructions and ran into a few issues:

Russs-MBP:WebstormProjects russwatson$ foundation-apps new testFA

/|
| | /| .
. /\| \/ |/|
|\/ |
||\__/\____/|| Thanks for using Foundation for Apps!
___|| ======== ||___ -------------------------------------
/___|| O O ||___\ Let's set up a new project.
|| ______, || It shouldn't take more than a minute.
/| |\
/_/\\/\ /\//\_\
\/\\//\/
\/

Downloading the Foundation for Apps template...
Done downloading!

Installing dependencies...
npm => bower => bundler

You're all set! Now run foundation-apps watch while inside the testFA folder.

Russs-MBP:WebstormProjects russwatson$ cd testFA/
Russs-MBP:testFA russwatson$ foundation-apps watch

> foundation-apps-template@0.0.1 start /Users/russwatson/WebstormProjects/testFA
> gulp

Error: Cannot find module 'gulp-front-matter'
at Function.Module._resolveFilename (module.js:338:15)
at Function.Module._load (module.js:280:25)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object. (/Users/russwatson/WebstormProjects/testFA/gulpfile.js:4:22)
at Module._compile (module.js:456:26)
at Object.Module._extensions..js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)

npm ERR! foundation-apps-template@0.0.1 start: `gulp`
npm ERR! Exit status 8
npm ERR!
npm ERR! Failed at the foundation-apps-template@0.0.1 start script.
npm ERR! This is most likely a problem with the foundation-apps-template package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! gulp
npm ERR! You can get their info via:
npm ERR! npm owner ls foundation-apps-template
npm ERR! There is likely additional logging output above.
npm ERR! System Darwin 14.0.0
npm ERR! command "node" "/usr/local/bin/npm" "start"
npm ERR! cwd /Users/russwatson/WebstormProjects/testFA
npm ERR! node -v v0.10.31
npm ERR! npm -v 1.4.23
npm ERR! code ELIFECYCLE
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /Users/russwatson/WebstormProjects/testFA/npm-debug.log
npm ERR! not ok code 0

Screen shot 2014 12 05 at 1.26.55 pm

No problem, I did 'npm install gulp-front-matter'. I subsequently received errors for the following packages:

"gulp-ruby-sass"
"gulp-concat"
"gulp-connect"

Now I'm running into an issue where the server that is started at 8080 returns no response and I'm scratching my head trying to figure out what's going on:

[12:13:28] Using gulpfile ~/WebstormProjects/testFA/gulpfile.js
[12:13:28] Starting 'build'...
[12:13:28] Starting 'clean'...
[12:13:28] Starting 'server:start'...
[12:13:28] Finished 'server:start' after 18 ms
[12:13:28] Finished 'build' after 20 ms
[12:13:28] Starting 'default'...
[12:13:28] Finished 'default' after 13 ms
[12:13:28] Server started http://localhost:8080
[12:13:28] Finished 'clean' after 38 ms
[12:13:28] Starting 'copy'...
[12:13:28] Starting 'clean-partials'...
[12:13:28] Starting 'sass'...
[12:13:28] Starting 'uglify-angular'...
[12:13:28] Finished 'clean-partials' after 13 ms
[12:13:28] Starting 'copy-partials'...
[12:13:28] Finished 'copy-partials' after 5.6 ms
[12:13:30] Finished 'copy' after 1.8 s
[12:13:30] Finished 'uglify-angular' after 2.24 s
[12:13:30] Starting 'uglify'...
[12:13:30] gulp-ruby-sass: directory
[12:13:31] Finished 'uglify' after 499 ms
[12:13:33] gulp-ruby-sass: write app.css
write app.css.map
[12:13:34] Finished 'sass' after 5.76 s
[12:13:34] Starting 'copy'...
[12:13:34] Finished 'copy' after 5.25 ms
[12:13:34] Starting 'copy-templates'...
[12:13:34] Finished 'copy-templates' after 8.92 ms
Successfully built.

Screen shot 2014 12 05 at 1.31.43 pm

I'm continuing to try and sleuth this out, but has anyone already jumped this hurdle?

This post has been closed. No new replies can be added.

Russ Watson over 4 years ago

I had a different application using port 8080,

I updated the gulp.js file by adding a port property in the gulp-connect with an open local port as so:

gulp.task('server:start', function() {
connect.server({
root: './build',
port: 3100,
middleware: function() {
return [
modRewrite(['[\.]*$ /index.html [L]'])
];
},
});
});

Maybe the console output should reflect that the server couldn't be started on 8080?