Menu icon Foundation
"foundation-apps new myApp" error spawn ENOENT at line 130

just follows the getting started page but struggle in step 2 as show in below picture

> foundation-apps new myApp

How to solve this error? please suggest.

12 5 2014 9 41 48 pm

foundation for apps

just follows the getting started page but struggle in step 2 as show in below picture

> foundation-apps new myApp

How to solve this error? please suggest.

12 5 2014 9 41 48 pm
Paul J about 5 years ago

I'm getting a similar error except my errs on foundationCLI.js:118

john about 5 years ago

Yep.. .Same error for me as well.

Hans McMurdy about 5 years ago

I get the same error but when I go to set up the project it still works just fine...

If you want to fix it...
https://github.com/zurb/foundation-cli

Stefan Staudenmeyer about 5 years ago

Some error messages can be misleading, or not f***ing helping at all. I'm sorry to say this kids, but we're nodeing here, so the error can be anywhere or anything from cosmic radiation to pebkac.

Since this thing instanciates a connect instance, you might whant to make sure that nothing blocks the port 8080 on your local machine (linux users: netstat -tulpen | grep 8080, Mac/Windows users: lol). Since neither the config or the install of foundation4apps gives a dev the possibility to specify otherwise, connect tries to allocate this port on your machine, so you can start to dev on localhost:8080. Make sure it isn't blocked.

Also notice: Sometimes vagrant behaves strangely. A vagrant global-status might show you that a vm didnt shut down as noticed. ps aux ftw.

Robotrick about 5 years ago

"I'm getting a similar error except my errs on foundationCLI.js:118 "

getting the same error, has anyone found a solution for this?

Istvan Habencius about 5 years ago

"I'm getting a similar error except my errs on foundationCLI.js:118 "

My solution:

  • (re)install GIT for win (http://git-scm.com/download/win)
  • setting up PATH (C:\Program Files (x86)\Git\bin;C:\Program Files (x86)\Git\cmd)
  • restart cmd window

Stephen Martin almost 5 years ago

Reinstalling GIT as Istvan Habencius suggested cleared up this problem for me.

R Fletch almost 5 years ago

Istvan Habencius post started me in the right direction.

PATH to Git for me on Windows 7 was C:\Users<username>\AppData\Local\GitHub

Instructions on setting PATH http://geekswithblogs.net/renso/archive/2009/10/21/how-to-set-the-windows-path-in-windows-7.aspx

Also had to run "foundation-apps new myApp" and "npm start" from Git Shell

May not need to re-install GIT. Try setting PATH first.

Geoff Kimball almost 5 years ago

Hey guys,

As a few others have mentioned, it's sometimes a case of not having all the right software installed ahead of time. ENOENT sometimes indicates that a command the CLI is trying to execute (e.g. npm, bower, bundle, git), although it's also sometimes a permissions error.

If you can't get the CLI working, you can also manually install the template stack:
- git clone https://github.com/zurb/foundation-apps-template.git app
- cd app
- [sudo] npm install
- bower install
- [sudo] bundle

And then foundation-apps watch to run the build process.

Note that if you're on OS X or Linux, depending on how Node and Ruby are configured on your machine you may need to add sudo to the beginning of some of the commands, as shown above.

We're working on some upgrades to the CLI that will improve error handling and generally make things more stable. You can see our progress on that on GitHub.