Menu icon Foundation
Error Message Installing Foundation With Apps

I saw there was a post already but it was referencing Node using Mac and homebrew. My instance is a little different. I re-installed a fresh download of Node, Ruby 1.9.3 and Git. I followed the instructions and am getting the following error messages

Foundationwithapps

errornpmfoundation for apps

I saw there was a post already but it was referencing Node using Mac and homebrew. My instance is a little different. I re-installed a fresh download of Node, Ruby 1.9.3 and Git. I followed the instructions and am getting the following error messages

Foundationwithapps
Alec Gregory over 4 years ago

I get the same error on windows 7 and Windows server 2008

ayezee over 4 years ago

I'm bummed because I have been waiting for a while to tune one of these up. I am curious what is going on because I got my Mac out and fired everything up and got errors when trying to launch gulp.

I am running WAMP on my desktop and wondering if that is messing with Gulp. I looked through my npm-error.log file but am not a programmer by any means

John Bortins over 4 years ago

I also had error mssages. Turned out I needed to install sass 3.4.7 rather than sass 3.4.9

Michael Frohberg over 4 years ago

I would suggest running npm install again in your project directory as the debug log says it can not find a module.

Hans McMurdy over 4 years ago

I've gotten this error more then a few times. Installing foundationforapps is still really buggy. I've had npm install fails as well. I recommend deleting all the node modules and rerunning npm install because that has helped me a few times.

Clara over 4 years ago

There's an open issue at github with a manual fix, if it's any help

https://github.com/zurb/foundation-apps/issues/203

Nando Boronat over 4 years ago

Error downloading the Foundation for Apps template...

C:....\lib\foundationCLI.js:115

Error: spawn ENOENT

at errnoException (child_process.js:1001:11)
at process.Childprocess._handle.onexit (child_process.js:792:34)

I am only a web designer and developer...

Nando Boronat over 4 years ago

Your environment has been set up for using Node.js 0.10.33 (x64) and npm.

C:\Users\Nando>gem install builder
Fetching: builder-3.2.2.gem (100%)
Successfully installed builder-3.2.2
Parsing documentation for builder-3.2.2
Installing ri documentation for builder-3.2.2
Done installing documentation for builder after 1 seconds
WARNING: Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/latest_specs.4.8.gz)
1 gem installed

C:\Users\Nando>foundation-apps new myApp

       /|
      | |  /| .
 .  /\|  \/ |/|
 |\/          |
 ||\__/\____/||         Thanks for using Foundation for Apps!

|| ======== || -------------------------------------
/|| O O ||\ Let's set up a new project.
|| _____, || It shouldn't take more than a minute.
/| |\
/
/\/\ /\//_\
\/\//\/
\/

Downloading the Foundation for Apps template...
C:\Users\Nando\AppData\Roaming\npm\node_modules\foundation-cli\lib\foundationCLI
.js:115
if (err instanceof Error) throw err;
^
Error: spawn ENOENT
at errnoException (child_process.js:1001:11)
at Process.ChildProcess._handle.onexit (child_process.js:792:34)

C:\Users\Nando>

Cameron Wilson over 4 years ago

Hi folks, I have managed to install and get an app running using the manual install. There seems to be an issue with SASS. If you are using Sass version 3.4.9 then downgrade to version 3.4.7. This seemed to work for me. Uninstall 3.4.9 by running the command: gem uninstall sass -v "3.4.9" , then run the command: gem install sass -v "3.4.7" . This may work for you also.

Nando Boronat over 4 years ago

Hi, Thnks.
I tried to downgrade SASS but the certificate problem remains.

 C:\Users\nandell>gem install bundler
ERROR:  Could not find a valid gem 'bundler' (>= 0), here is why:
          Unable to download data from https://rubygems.org/ - SSL_connect retur
ned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (
https://api.rubygems.org/latest_specs.4.8.gz)

C:\Users\nandell>gem uninstall sass -v "3.4.9"

C:\Users\nandell>gem install sass -v "3.4.7"
ERROR:  Could not find a valid gem 'sass' (= 3.4.7), here is why:
          Unable to download data from https://rubygems.org/ - SSL_connect retur
ned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (
https://api.rubygems.org/specs.4.8.gz)

C:\Users\nandell>gem install builder
ERROR:  Could not find a valid gem 'builder' (>= 0), here is why:
          Unable to download data from https://rubygems.org/ - SSL_connect retur
ned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (
https://api.rubygems.org/latest_specs.4.8.gz)

Rafi Benkual over 4 years ago

You can follow this post that has a solution and we're looking into: http://foundation.zurb.com/forum/posts/21148-foundation-apps-new-myapp-error-on-line-130