Menu icon Foundation
Updated to 5.4.6 no styles for grid, typography, etc in app.css

I updated a project to 5.4.6 and all the styles for the grid, typography, etc have gone.

They are not present in the app.css

I made the update using Codekit's features for updating installed components.

The project is "without compass".

Any ideas?

5.4.6missing styles

I updated a project to 5.4.6 and all the styles for the grid, typography, etc have gone.

They are not present in the app.css

I made the update using Codekit's features for updating installed components.

The project is "without compass".

Any ideas?

Roger Coathup almost 5 years ago

Update.

I switched the compiler in Codekit to libsass, and that appears to have corrected the problem.

Roger Coathup almost 5 years ago

Updated another site, and same problem.

This switching the compiler to libsass has not fixed the problem.

Any thoughts?

Roger Coathup almost 5 years ago

fixed again -- had a config.rb left over from compass setup.

Removed that, and compiled correctly.

Eberth Manjarrez almost 5 years ago

How do you switch to libsass in CodeKit?

Eberth Manjarrez almost 5 years ago

nevermind, found it!

Brett Peary almost 5 years ago

For anyone else who is seeing this later on...

If you are using Codekit and switch to Libsass to correct this problem, make sure you are not using Compass (i.e. delete the config.rb file in the main directory).

I already was using Compass so when I tried to fix it with Libsass, it wasn't working until I got rid of Compass.

Christopher Winch almost 5 years ago

I think i may be having this same problem but i am not using codekit.
Im using compass in the terminal.

You can view the forum post i made about it here: http://foundation.zurb.com/forum/posts/19958-layout-breaks-after-a-clean-install-of-compass-foundation-etc

Any ideas on how i would go about fixing my site? Any help would be appreciated.
Thanks.

Andrew Sim almost 5 years ago

Christopher,

There is a related thread here that seems like a temporary fix for you:

http://foundation.zurb.com/forum/posts/19869-updated-to-546-styles-not-included-in-appcss-for-compass-build

Christopher Winch almost 5 years ago

Thanks alot, that has solved it.

Christopher Winch almost 5 years ago

Hi again.
I have now noticed that by adding the fix from the thread 'Design Dabble' mentioned it has now broke all ie9 support.

Is there anyway of fixing that?

Thanks,
Chris