Menu icon Foundation
SASS with libsass (error like in sass 3.4)

Hi,
I am trying to use the foundation SASS version using libsass by starting a project with 'foundation new --libsass' command. When I build using 'grunt build', I get a css file about 320 KB in size. This file resembles the file generated by sass version 3.4 (which is said to be incompatible with foundation). If I try to install using compass, this error is not occuring (as it uses sass 3.3.14 in my system).

npm list | grep sass
[email protected] /home/xxxx/workspace/test
├─┬ [email protected]
│ └─┬ [email protected]
└─┬ [email protected]
  ├─┬ [email protected]

Can this problem be avoided if I use any particular version of grunt-sass or node-sass?

PS: I use grunt to join and minify only the foundation js modules that I use (and also my custom js apps), so I would prefer to use the grunt + libsass version of foundation.

SassGrunt

Hi,
I am trying to use the foundation SASS version using libsass by starting a project with 'foundation new --libsass' command. When I build using 'grunt build', I get a css file about 320 KB in size. This file resembles the file generated by sass version 3.4 (which is said to be incompatible with foundation). If I try to install using compass, this error is not occuring (as it uses sass 3.3.14 in my system).

npm list | grep sass
[email protected] /home/xxxx/workspace/test
├─┬ [email protected]
│ └─┬ [email protected]
└─┬ [email protected]
  ├─┬ [email protected]

Can this problem be avoided if I use any particular version of grunt-sass or node-sass?

PS: I use grunt to join and minify only the foundation js modules that I use (and also my custom js apps), so I would prefer to use the grunt + libsass version of foundation.

Julian Ćwirko about 5 years ago

It could be related with this problem: https://github.com/zurb/foundation/issues/5863