Menu icon Foundation
Problem with command yo zf5

Ss001

I use windows 8 and did sucess setup (git +node.js +bowel+zurb foundation+grunt+yeoman)

I did sussess setup generator-zf5 and already created with command yo zf5.

Today I face with error as picture , mentioned that , there are 2.4.1-package-tgz in folder lodash within npm-cache folder. Therefore I go to delete all concerning , even delete temp file in windows temp folder.

I try many effort to do again and again and restart manytime but no luck.
once repeat command yo zf5 , a previous problem is come again.

It'll be the most appreciate if someone can help.

Thank you.

generator zf-5error

Ss001

I use windows 8 and did sucess setup (git +node.js +bowel+zurb foundation+grunt+yeoman)

I did sussess setup generator-zf5 and already created with command yo zf5.

Today I face with error as picture , mentioned that , there are 2.4.1-package-tgz in folder lodash within npm-cache folder. Therefore I go to delete all concerning , even delete temp file in windows temp folder.

I try many effort to do again and again and restart manytime but no luck.
once repeat command yo zf5 , a previous problem is come again.

It'll be the most appreciate if someone can help.

Thank you.

Nont Nawa almost 5 years ago

I go back to see detail carefully, go to delete all in npm-cache foder.
once install yo zf5 is done. Have to 'npm install' one more time
and then it can started connect web server on http://127.0.0.1:9000

However , still have error Error: Cannot find module 'imagemin-gifsicle'

Hmmm.. quite complicated. anyway it's now can work.

Julian Ćwirko almost 5 years ago

Hi, 'npm cache clean' can sometimes help... and what version of npm are you running? (npm --version) and (node --version)

edit:
ops, I see it now :)
I wonder if new 2.0.2 version of npm could help with this... need to try it later..

Nont Nawa almost 5 years ago

Hi , Julian

yes, as in picture

npm 1.4.28
node v0.10.32

how can I update npm with the properly command between npm update or npm install latest. ?

Julian Ćwirko almost 5 years ago

If you want to update npm I think 'npm update -g npm' should work

Nont Nawa almost 5 years ago

Hi Julian I updated npm already , unfortunately still has same error with 2-4-1-package.tgz and error can not find module imagemin-gifsicle.
Just tell you if lucky you can found a cule.. bye