Menu icon Foundation
Media queries working on desktop resize, not on actual devices

I am rebuilding a Foundation 5 theme for a ZenCart site (urghhh) using the SASS version of the framework. This all seemed to be going well until I actually tried it on an iPhone, where I noticed that none of the breakpoints are working.

If I resize my Firefox, Chrome or Safari browser in the desktop the media queries work correctly (initially it's just a small-12 medium-6 grid, and a block grid). However viewing the site on an actual phone, or on an iPhone simulator shows the 'large screen' HTML.

I have checked using Firebug that the classes are applied correctly on resize, but I can't debug in this way on the phone.

Any pointers as to where I should be looking for the cause of the problem? I've built quite a few sites using Foundation and never had this happen before!

The site is regencychess.co.uk/rwd

Thanks

Foundation 5media queriesmobile device

I am rebuilding a Foundation 5 theme for a ZenCart site (urghhh) using the SASS version of the framework. This all seemed to be going well until I actually tried it on an iPhone, where I noticed that none of the breakpoints are working.

If I resize my Firefox, Chrome or Safari browser in the desktop the media queries work correctly (initially it's just a small-12 medium-6 grid, and a block grid). However viewing the site on an actual phone, or on an iPhone simulator shows the 'large screen' HTML.

I have checked using Firebug that the classes are applied correctly on resize, but I can't debug in this way on the phone.

Any pointers as to where I should be looking for the cause of the problem? I've built quite a few sites using Foundation and never had this happen before!

The site is regencychess.co.uk/rwd

Thanks

Martyn James about 3 years ago

Gah!!!

I've been struggling with this for hours, and I spotted the problem as soon as I posted :-)

Being ZenCart, there are lots of PHP conditionals in the head. I had got my viewport meta stuck inside one of those, so it wasn't loading!!

Sorry to have bothered you all...